Thread Rating:
  • 21 Vote(s) - 1.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hard to start but runs fine when started
Hiya all again ive a 53 plate beringo Thk dw8 engine

Well just recently its been a pain to start when started it runs perfect allday without fault covered 500 miles this weekend in it

Ive changed fuel filter and checked for any leeks but cannot seem to find any

Im having to prime pump under engine to get it going in the morning before this it was perfect i just cant understand whats happened to it any advice would be Great

Thanks all Muply
How old are the glow plugs?

Have you had a look at the connectors to them to make sure they are clean and there's no damage?
Sounds just like some of your glow plugs need replacing. It is typical for the Berl to be a hard start first thing if some need replacement, especially since with the temperature dropping.
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

iv e got same problem with mine glowplugs changed for new ones and checked they all workin but bein a real pig to start once started runs fine !
Unsure how old glowplugs are but i will check today and get back to you all Many Thanks
My wife's corsa diesel was playing up and two of the glow plugs were black, one was a little loose and the connectors to them were crusty and rusty.

changed the plugs and cleaned up the connectors with contact cleaner and it's been spot on ever since.

Either way, it's worth doing for the price of a set of plugs.
Will have a good look the weekend or hopefully sooner just so cold outside Just another quickie when my berlingo gets just before fuel light its naughty power loss cutting out and just sluggish this is the reason i changed fuel filter any body else suffer from this or is it just me apart from these things its good as gold Thanks in advice Lads
mines same engine mate,
had exact same problem, black coming from exhaust after a struggle to start.
Changed glowplugs and battery as battery been on the blink too, and now starting perfect, but it would work all day fine, starting and stopping, just first start of every morning. Really easy to replace on that engine too.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Last Post:geoff
Today 02:58 PM
» Replies: 1
» Views: 38
Electrical Fault
Last Post:Traveling Man
Today 10:46 AM
» Replies: 0
» Views: 39
Diesel fan in Petrol engi...
Last Post:Johny555
Today 10:34 AM
» Replies: 1
» Views: 39
Wanted Berlingo / Partner...
Last Post:b-f-c
Today 08:32 AM
» Replies: 0
» Views: 53
Eco activated but engine ...
Last Post:brajomobil
Today 08:10 AM
» Replies: 13
» Views: 329
WTB Rear Hatch in Silver,...
Last Post:Def-fid
Today 07:56 AM
» Replies: 0
» Views: 33
font fog light bulb chang...
Last Post:Luis Rosa
Today 05:31 AM
» Replies: 2
» Views: 67
Putting spare back into c...
Last Post:Col
Yesterday 10:59 PM
» Replies: 7
» Views: 156
B9 Steering wheel
Last Post:Dandav1985
Yesterday 08:48 PM
» Replies: 1
» Views: 70
TDI Tuning, Tuning box fo...
Last Post:Dandav1985
Yesterday 08:46 PM
» Replies: 3
» Views: 188

Locations of visitors to this page