Thread Rating:
  • 14 Vote(s) - 2.93 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speedo/BSI problem
#1
3 years ago the instrument cluster on our year 2000 1.9 Berlingo went kaput, temp and fuel gauges stopped working the rev counter and then mileometer went to 600000 and stuck. Tried a couple of second hand clusters but they had faults and so lashed out on a new cluster (needed a mortgage), everything is working file except for mileometer which still says 600000. We hav put up with it for all this tome but now the other half would like it fixing. The local Citroen dealer says that it can be fixed but they will not fix it because of the problem of "clocked" cars. Apparently the mileage is stored in both the cluster and the BSI and the 600000 is a Citroen default when things go wrong. Does anyone know of a fix? can this be put right using Lexia. We are willing to pay if it can be done.

Peter
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Roof noise
Last Post:Shawks
Today 12:03 PM
» Replies: 6
» Views: 155
Poor cold startup 1.9
Last Post:CHRISPY59
Today 11:42 AM
» Replies: 16
» Views: 511
Heyup
Last Post:ffrenchie
Today 11:08 AM
» Replies: 6
» Views: 280
Haynes manuals - which on...
Last Post:b-f-c
Today 10:25 AM
» Replies: 2
» Views: 32
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 31
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Today 10:01 AM
» Replies: 9
» Views: 172
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 170
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 162
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 273
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 144

Locations of visitors to this page