Thread Rating:
  • 38 Vote(s) - 2.87 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Airbag warning light-passenger side
#1
Another niggling fault developed today.
Wife returned from shopping expedition and said amber light on l.h.s. of instrument panel permanently lit and audible bleeper going off.
Quick investigation in the dark revealed that the passenger side air bag de-activation light was illuminated, apparently a common fault on earlier Berlingos.
A quick "wiggle test" of the seat-belt pre-tensioner connector beneath the passenger seat (sods law could not get the connector apart) and still lit.
Ran the engine up and anticipated a trip to the main (st)dealer,
light suddenly went out, quick road test and now back to normal.

Tempremental little soul, mais oui nes't pas!!!
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#2
I had my light come on a while back now. I dont have passenger airbags well at least think not. when I hit the horn at someone who pulled out at me at a roundabout the light went out. Hasn't been back on since

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
Reply
#3
Nice one ,usually by the time i have found the horn its all over.
Reply
#4
I know what you mean with that, but have been finding the horn a lot more recently

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
Reply
#5
Little beggar came back again two days ago, User manual says light shown in position on light cluster l.h.s. is for passenger airbag fault ???, this led me up the wrong tree and to looking beneath the passenger side with no joy then I ran out of time. Thinking again about it I have only seen one airbag light on the panel for the whole system so today I took a quick look beneath the driver's seat. Did a quick "wiggle" of the connectors and lo and behold, it is working again.

Don't hold your breath, I and not 100% confident that I have fixed it. In the event it is still covered by a Citroen Select Warranty so hopefully ifit ain't fixed they will do the job under a warranty claim.
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#6
Just seen this post.

Classic fault with berlingos this one. Connector under drivers seat works loose with seat adjustment, Usually a quick squirt with wd40 on both parts of the connector will sort it. No worries!!
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
[+] 1 user says Thank You to adam3rdcanvey for this post
Reply
#7
(08-03-2011, 04:57 PM)adam3rdcanvey Wrote:  Classic fault with berlingos this one. Connector under drivers seat works loose with seat adjustment, Usually a quick squirt with wd40 on both parts of the connector will sort it. No worries!!

Thanks for confirming that, last occurence was at end of January when I did the quick "Wiggle-Wiggle" with the connector and it has since (Touch Wood) been ok to date.

Still haven't got back to sussing out the other connector under the seat which appears to be already connected to the seat squab as if it is already wired (but not connected up) for a heated seat, but that is for another day.

Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#8
Yep..... Heated seats available as an option an non UK models I think? Wiring is standard throughout, all wires in place even when the end component is absent. My van examples: front tweeters, rear heated screen..... could be more haven't had all the trim off!

Would LOVE a heated seat though.................................
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#9
I had my light come back on but gave a wiggle and it went. Will keep the wd40 in mind, would gt85 work the same though? I have that laying around from when I used to cycle.

Lliam
Lliam

53 plate Berlingo Multispace Forte 1.9D Polar White
Reply
#10
Yep GT85 smells nicer too, and brings up your dashboard really shiny......................... strange what ya learn...
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold startup 1.9
Last Post:Sootyfoot
Today 12:34 PM
» Replies: 37
» Views: 984
Reverse light switch prob...
Last Post:Sootyfoot
Today 12:32 PM
» Replies: 8
» Views: 183
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 12:21 PM
» Replies: 0
» Views: 8
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 58
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 70
Trip Computer on Type A M...
Last Post:cancunia
Today 09:18 AM
» Replies: 1
» Views: 50
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 108
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 43
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 81
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 56

Locations of visitors to this page