Thread Rating:
  • 29 Vote(s) - 3.59 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screen Wash Pump and Diesel Preheat

If anyone can help diagnose this problem it'd be appreciated.

At the same time the screen wash pump and the diesel preheat light on the dash seem to have stopped working. I thought it must have been a fuse but can't see any blown.

If anyone has any ideas...


Adri is it just the preheat light or is it not preheating ?
I think it is preheating as the car starts just the same. Can't be 100% certain though. I'm sure it's an electrical fault as the two systems have died at the same time.

Scanning through my Haynes manual at the moment but I don't find them very good for diagnosing...

Thanks for the replies.

Sounds like a fuse you may need to test them with a meter or by replacement as you can not always see that they have blown
You can check out a fuse guide here:
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

If not a fuse maybe the bulbs? Just a suggestion. With the Haynes manual you should be able to work your way into the instrument panel


53 plate Berlingo Multispace Forte 1.9D Polar White
Does your pre-heat light come on that much anyway? Mine only ever comes on when it's really cold.
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
My pre-heat light shows up even on a hot day. If it's hot it's only for a second. But cold it's on a bit longer


53 plate Berlingo Multispace Forte 1.9D Polar White
My preheat has only been on in the cold weather but the washers to both front and rear screen have been a bit problematic during the freezing weather. The washer jets (presumably) seem to freeze up at the slightest hint of frost so I've been putting a drop of methylated spirits in with the screenwash water to prevent freezing.
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
re-I've been putting a drop of methylated spirits in with the screenwash water to prevent freezing

dont think I will try that, the last thing I want is a couple of drunks sucking on my nipples

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Eco activated but engine ...
Last Post:doofer
Today 01:13 PM
» Replies: 15
» Views: 345
Berlingo VTR to ''XTR'' l...
Last Post:doofer
Today 12:58 PM
» Replies: 4
» Views: 172
cooling fans
Last Post:blueiceplus
Today 12:57 PM
» Replies: 0
» Views: 4
OBD Eror Code P1351
Last Post:PeteK
Today 11:11 AM
» Replies: 5
» Views: 132
font fog light bulb chang...
Last Post:rdfb2
Today 10:27 AM
» Replies: 3
» Views: 82
Last Post:my mucker
Today 10:17 AM
» Replies: 2
» Views: 97
Cruise control possible o...
Last Post:cancunia
Today 09:43 AM
» Replies: 1
» Views: 49
Front camber out of align...
Last Post:Civvic
Today 09:21 AM
» Replies: 4
» Views: 67
How the heck do I remove ...
Last Post:CourierJim
Yesterday 11:20 PM
» Replies: 7
» Views: 564
Wanted Berlingo / Partner...
Last Post:Matt Haigh
Yesterday 09:41 PM
» Replies: 1
» Views: 77

Locations of visitors to this page