Thread Rating:
  • 8 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Anybody solve the automatic left indicator issue?
#1
Hi All

When I indicate to turn right, the self cancelling indicator goes straight to a left turn and not the cancel position.

I have read the thread about making a left turn to compensate Smile

Any other solutions?

Happy New Year

CraigE
Reply
#2
Have a look at the last post here:-

http://www.berlingoforum.co.uk/showthrea...9#pid14309
Reply
#3
The solutions could vary, depending on your mechanical ability.
The problem is not uncommon on MkI and earlier MkII Berlingos and the other Citroen models which share the same COM2000 unit.
If you take it along to a Dealer or approved repairer a new COM2000 will be fitted.
It is possible to strip out the existing unit and modify the switch return mechanism by removing the auto-return latch then
you have a switch which will require manually cancelling the indicators (like older cars used to have).
I think that the COM2000 has to be completely removed to carry out this work and in order to remove it the steering wheel air-bag
assembly also has to come off.
There are existing posts here which describe the removal of the COM2000. In fact Andre has recently posted a tutorial with pictures.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#4
OMG, that sounds expensive or very complicated.

May put up with it for now.

Thanks for the constructive replies
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 62
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 56
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 54
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 232
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1107
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 321
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 285
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page