Thread Rating:
  • 15 Vote(s) - 3.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Both Break Lights Not Working
#1
just looking for some info on this ,I have been doing a lot of research :eek:on this ,
my both brake lights are not working and i have change the bulbs but still not working , Im thinking that it might be brake switch can any1 advise me on how to check this( I know its somewhere near the brake pedal) or is it a fuse ,
Thank you in advance for help .

oh yes my van is up for psv on friday would like to get it passed so i dont fork out £18 for retest Confusedcratch:
Reply
#2
Should be a free retest, shop around, what are you paying at that garage?

Does the top brake light work? Most likely your brake light switch which is just above the pedal itself IIRC.
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
The switch is on the pedal box.Disconnect the plug,join the two plug terminals with a handy bit of wire,turn ignition on,run round the back & check if stop lights are on.If they are,check the switch plunger is free.They can get dusty etc & stick.If it's sticky,squirt Wd40 on it while pushing it in & out(the plunger).Try before refitting.As a rough adjustment push the pedal 2-3mm before the plunger touches it.Good luck & welcome to the forum.
Strawberry flavoured windows  Dodgy
Reply
#4
(07-01-2012, 11:33 PM)ron Wrote:  The switch is on the pedal box.Disconnect the plug,join the two plug terminals with a handy bit of wire,turn ignition on,run round the back & check if stop lights are on.If they are,check the switch plunger is free.They can get dusty etc & stick.If it's sticky,squirt Wd40 on it while pushing it in & out(the plunger).Try before refitting.As a rough adjustment push the pedal 2-3mm before the plunger touches it.Good luck & welcome to the forum.

do you think that it is most likely it is brake switch ?
and do i need to unscrew the 2 screws from the fuse box to get at the switch ,

Reply
#5
I took off the brake switch to have a look it seems that the plunger (the bit inside the black thread) is flush at the end , I tried to free it abit with wd 40 but it doesnt seem to come out a bit further ! Does this mean i need to get new brake switch ?
I had looked at some of the pictures on ebay of brake switches and it looks like that the plunger seems to be further out more .
Thanks guys in advance
Reply
#6
(08-01-2012, 11:48 AM)Raymi5 Wrote:  ! Does this mean i need to get new brake switch ?

Yes. Switch must be replaced.
Reply
#7
Thank you very much you guys :thumbsup:
pk7478
ron
Andre
I will get one asap for psv on friday , I will let you know if brake lights working when I get the switch .
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 92
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 29
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 58
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 32
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 34
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 270
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 84
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 32
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 116
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 474

Locations of visitors to this page