Thread Rating:
  • 21 Vote(s) - 3.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pollen Filter
#1
Hi

I'm servicing my 53 plate Berlingo and on the pollen filter... problem is I can't find it and the more I search it seems apparent it isn't there. I have not got A/C which the more I search about online seems asthough you only have a pollen filter if you have A/C. Can anyone shed some light on this?

Thanks Lliam
Reply
#2
From memory lem they are on the passenger side under the dash/footwell. There is a plastic cover over it that you need to unscrew-a-screw to get to it.

And i think i have had a car in the past with a pollen filter but without air con, but im not totally sure.
Reply
#3
Oh right thanks, I'll have to have another look for the screws, I run out of daylight aswell so it didn't help lol.

Thanks Lliam
Reply
#4
I was changing the catalyst on my 206 today, the bottom of it decided to snap at 1am last night, so it was a noisy journey home.

The reason i brough it up was because i ran out of day light putting the new one on today! So i wasn't alone chasing the sun. Smile
Reply
#5
Damn that sunlight lol. Had another look for filter but just couldn't find it. I guess I don't have a pollen filter in my berlingo.

Lliam
Reply
#6
I like pollen filters, but I've never had one on a car without a/c

The usual indication for a change is constantly misting windows when the blower is on but the setting is to "fresh air" not "recirc".
Dave.

08 Citroen Berlingo MkIII 1.6 hdi Vtr 90. It's gone. 'Twas a bad'un.

Yes I am an angry old fart.
Reply
#7
Did you find the filter lemsworld?
Reply
#8
Nope no luck whatsoever. It's a solid mass of plastic to the right of the fan and couldn't find any screws

Lliam
Reply
#9
Im fairly sure it was only fitted on cars with Air Con - I binned mine anyway and ran without it.
All worked fine.
[Image: 03329.gif]
Reply
#10
Just had a look in mine and found two phillips head metal screws. I have AC though.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 100
DW8 engine tapping
Last Post:Hector Scorn
Today 12:30 AM
» Replies: 0
» Views: 5
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 113
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 334
Loud beeping from radio u...
Last Post:Tonyash
Yesterday 10:13 PM
» Replies: 0
» Views: 20
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 288
Reverse light switch prob...
Last Post:willpisme
Yesterday 08:09 PM
» Replies: 7
» Views: 158
Rear hub nut torque setti...
Last Post:geoff
Yesterday 07:31 PM
» Replies: 4
» Views: 88
Heyup
Last Post:polar
Yesterday 07:18 PM
» Replies: 9
» Views: 372
New owner
Last Post:SheilaAnn
Yesterday 04:33 PM
» Replies: 12
» Views: 585

Locations of visitors to this page