Thread Rating:
  • 10 Vote(s) - 1.8 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MK3 FRONT BRAKES
#1
Suspect the o/s front disc pads are not freeing off properly as I am getting an intermittent binding noise and the disc is getting rather hot.
No signs of a leak and B/fluid level is okay.

woodshaper
[fon‌t=Times New Roman]Sole Member and President for LIFE![/font]
Reply
#2
Not had anything noticable on mine. But on my ZX sticking calipers were a problem, and I was told it was a common issue with citroens. But that was a car from 15 years ago. Surely they've got better since then.
The Bus: 2009 MkIII VTR HDi 90, 7 Seater
Reply
#3
I have looked on the Forum and found the *same fault reported on the MK2's caused by a faulty Valve on the Servo/faulty Servo, could just be a coincidence of cause it may well be something else?
Taking it into Garage On Monday, to a small specialist Citroen/Renault place with people who know what they are doing. (proper Mechanics)

Hopefully whatever is wrong won't cost me an arm and a leg!

Covered over 61,000+ miles so far, other than the ********* Tyre Wear and Timing Belt problems have also replaced the Clutch and Disc/pads, My Berli is running well and I STILL LIKE IT!
Rattles, did I mention rattles...................................................................................................................................and not finding/having enough room to park it round here:S

woodshaper

*This Forum is brilliant Andre:thumbsup:
[fon‌t=Times New Roman]Sole Member and President for LIFE![/font]
Reply
#4
(26-01-2012, 05:43 PM)woodshaper Wrote:  Suspect the o/s front disc pads are not freeing off properly as I am getting an intermittent binding noise and the disc is getting rather hot.
No signs of a leak and B/fluid level is okay.

woodshaper

Hi woodshaper, just on with my brakes, same thing but mk2, right front stuck on, the pad material as come away from its backing,( bosch brakes) I suppose this is with getting very hot. I did notice that when braking hard the back of the van sat down abit, rear brakes getting to much pressure, pressure valve on rear could have sized up, it a tin of wd40 and a hammer job to get the arm working, will let you know the outcome, am doing it today.:brickwall:
[+] 1 user says Thank You to bechstein for this post
Reply
#5
Best of luck bechstein! My pads sometimes free off and sometimes don't??????????????????????????????????

woodshaper
[fon‌t=Times New Roman]Sole Member and President for LIFE![/font]
Reply
#6
After stripping and cleaning the corrosion off both front brakes, problem solved!

woodshaper
[fon‌t=Times New Roman]Sole Member and President for LIFE![/font]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 133
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 44
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 18
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 276
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 80
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 73
Bottom Ball joint
Last Post:Andyy
Yesterday 08:26 PM
» Replies: 6
» Views: 84
cutting out HDi 1.6 diese...
Last Post:Col
Yesterday 06:15 PM
» Replies: 18
» Views: 1437
Poor cold startup 1.9
Last Post:Top drive
Yesterday 06:10 PM
» Replies: 34
» Views: 810
starting problem
Last Post:brodfather11
Yesterday 03:32 PM
» Replies: 1
» Views: 45

Locations of visitors to this page