Thread Rating:
  • 6 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
speedometer?/new clutch
#1
can someone help i had new clutch fitted last saturday on my 53 plate hdi berli i just noticed today when going to work that speedometer was irratic it does nothing until you are over 50mpg and even then goes right down and up again its all over the place i know speedo was ok before can anyone explain is there some sensor about where clutch is fitted or other reason i am not great with mechanics thanks.
Reply
#2
well nobody seems to know ah well i will find answer somewhere else
Reply
#3
Sorry you have had no answer to date.My only suggestion is to check the speed sensor/connections above the L/H driveshaft.It would have been disconnected when the gearbox was removed.Good luck.
Strawberry flavoured windows  Dodgy
Reply
#4
Mine has done that for the last two years, one week it's ok, next week it's all over, pain in the arse! MUST get round to changing the sensor!
Somedays you're the pigeon, Somedays you're the statue.
Reply
#5
thanks ron and steve for reply went back to garage who done clutch i knew the would plead no nothing to do with us after a bit of ranting by myself which i know it was working perfect before clutch change they got auto electrician in and he sorted out he said he put new sensor on but the other one maybe still ok he said its when you disturb them or something it knocks them out of sync.anyway thanks all
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 19
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 56
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 30
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 32
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 113
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page