Thread Rating:
  • 18 Vote(s) - 3.94 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dash lights. do I have ABS. Which radio
#1
Hi folks. This is my 1st post. Just bought our 1st family car and I am already starting to see how its kinda cool. I have a few questions wondering if anyone can advise. We have a January 2004 multispace Forte 2.0 diesel turbo. The ABS light on dash does not show on start up. Does this model have ABS? I know there is no ESP coz there is not an on of switch for it. I dont seem to have an oil warning light, coolant or emergency STOP light on start up either. I guess these are all linked in some way. Should all these dash lights eliminate briefly? I have seen a glimpse of a heater plug light so I know thats ok. Does anyone know of any particular issues with battery drain. One month old battery going flat over 2nights. All lights "in and out" off of course. Teething troubles only I hope. Oh and one more question if I may. The radio in this car is a cheap after market replacement that I would like to change. Does anyone have any model recommendations. I dont need anything flash just something that is compatible with the cars electrics. Thanks for reading folks.
Take care tommyx
Reply
#2
(21-02-2012, 04:35 PM)tommylurvebus Wrote:  Hi folks. This is my 1st post. Just bought our 1st family car and I am already starting to see how its kinda cool. I have a few questions wondering if anyone can advise. We have a January 2004 multispace Forte 2.0 diesel turbo. The ABS light on dash does not show on start up. Does this model have ABS? I know there is no ESP coz there is not an on of switch for it. I dont seem to have an oil warning light, coolant or emergency STOP light on start up either. I guess these are all linked in some way. Should all these dash lights eliminate briefly? I have seen a glimpse of a heater plug light so I know thats ok. Does anyone know of any particular issues with battery drain. One month old battery going flat over 2nights. All lights "in and out" off of course. Teething troubles only I hope. Oh and one more question if I may. The radio in this car is a cheap after market replacement that I would like to change. Does anyone have any model recommendations. I dont need anything flash just something that is compatible with the cars electrics. Thanks for reading folks.
Take care tommyx

Well my 2.0Hdi is a year older than yours and has ABS I am quite sure this was a standard fitment at the time. It sounds like you have a series of dash lights not working.
The easy was to get a working radio is to get an old Citroen one, but have a look through the posts on here as your wiring may need attention.
[+] 1 user says Thank You to Trevor for this post
Reply
#3
Hi there I have same model on an 04 plate and mine doesn't have it but I believe it was an optional extra but I may be wrong
Reply
#4
Mine is the 04 plate Desire but even then I had to specify ABS as an optional extra as part of the "safety pack" option at the time. If you have the passenger and seat shoulder airbags then IIRC they were the other parts of the deal. I think standard kit was just the drivers airbag .

Try a sharp stop on a gravel track if you want to see if its working.

[+] 1 user says Thank You to spiritdemon for this post
Reply
#5
Pretty sure abs was not fitted as standard in 2004. It's not fitted on my 2004.
The radio could be causing this battery drain if it's no been installed correctly.
Any after market head unit with a standard iso connection will fit.
Reply
#6
(21-02-2012, 07:05 PM)BerlingoHDI Wrote:  Hi there I have same model on an 04 plate and mine doesn't have it but I believe it was an optional extra but I may be wrong

Thanks. I am hoping there is no ABS as this is far better I think than having ABS with problems. Sure there must be some long term owners on here who may remember. Thanks to you and Trevor for speedy replies. I get the feeling this forum will be helpful. Cheers t
(21-02-2012, 07:20 PM)tucker Wrote:  Pretty sure abs was not fitted as standard in 2004. It's not fitted on my 2004.
The radio could be causing this battery drain if it's no been installed correctly.
Any after market head unit with a standard iso connection will fit.

I am feeling less worried Looks like there is a good chance there is no ABS then. The cheap radio was not working properly. It was a face off but when the face was on it the power button did not function "power always on". Of course I never left face on but I guess it may be possible the radio may have been drawing charge even when the face was off. I am pretty sure the lovely 5ft 2 Irish lady that sold us the car was not aware, so this may have been a new fault. As for the replacement iso ? Will google it. Thanks guys t
Reply
#7
My apologies for my misleading information, I thought that the bits I have were standard fitting. In my defence it was 8+ years ago I got the car and my memory was not up to much even then.

Reply
#8
(21-02-2012, 08:58 PM)Trevor Wrote:  My apologies for my misleading information, I thought that the bits I have were standard fitting. In my defence it was 8+ years ago I got the car and my memory was not up to much even then.

No worries Trevor I have been grateful for all responses and my initial thoughts were that ABS would be standard on a 2004 car too. But hey we have only owned the car 3 days and we are lovin it. Bags of bag space and bags of character to boot.
Reply
#9
Follow this link http://www.berlingoforum.co.uk/showthread.php?tid=251

Log in and enter your vehicles VIN & you can get a full spec on your vehicle
2003 Citroën Berlingo 2.0HDi Multispace Desire
[+] 2 users say Thank You to BlueBlingo for this post
Reply
#10
(21-02-2012, 07:25 PM)tommylurvebus Wrote:  Thanks. I am hoping there is no ABS as this is far better I think than having ABS with problems. Sure there must be some long term owners on here who may remember. Thanks to you and Trevor for speedy replies. I get the feeling this forum will be helpful. Cheers t

Owned mine from new in 2004. The official Berlingo brochure which I still have says ABS is extra, so yours will be highly unlikely to have it as it came as part of the extra safety pack.

Pretty much any stereo from Halfrauds will fit the car unless the original wiring has been tampered with.

I'd say the current one is wired wrong and a good chance it's permanently draining your battery from what you've described.

First thing to try is removing it completely and seeing if the battery problem goes.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Repair a manual winder wi...
Last Post:AbneyTeal
Today 12:25 PM
» Replies: 0
» Views: 3
Fuel consumption
Last Post:Wyvern
Today 11:18 AM
» Replies: 6
» Views: 94
12v for lighter front
Last Post:nicko
Today 11:09 AM
» Replies: 16
» Views: 340
1.6 16v petrol cambelt
Last Post:sks01773
Today 10:56 AM
» Replies: 14
» Views: 324
lubricating door
Last Post:sks01773
Today 10:52 AM
» Replies: 3
» Views: 97
how many miles on yours ?
Last Post:Wyvern
Today 10:27 AM
» Replies: 18
» Views: 814
Roof noise
Last Post:Opensauce
Today 09:59 AM
» Replies: 2
» Views: 70
Rear light Cluster
Last Post:Opensauce
Today 09:50 AM
» Replies: 3
» Views: 93
Saying Hello
Last Post:ghost123uk
Today 09:07 AM
» Replies: 2
» Views: 48
Lexia clone that works wi...
Last Post:brajomobil
Today 08:02 AM
» Replies: 59
» Views: 1863

Locations of visitors to this page