Thread Rating:
  • 10 Vote(s) - 3.1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.9D running issues
#1
Hey everyone.

A little before xmas my 2002 multi lost all power overnight, and I had no choice but to park it up and get a 1.6Hdi van. Its better in every way apart from the lack of seats, but I do get 50+ mpg and can overtake when I feel like it so I'm very pleased with it.

I'm now planning to fix my old mulitspace car and get a bit of money back from it as it's still tax'd and tested, which ain't cheap on one of those as you lot will know. I am doing the fix myself as Citroen said the engine diagnostic came up with a mine field.

If anyone has had similar issues or helpful tips I would be very grateful of some advice. Where I am so far is as follows.

Engine starts and Idles no problem. It has a Brand new battery, alternator, fuel line, very recently cleaned and refitted (by garage) injectors, plenty of clean fuel in the tank, all filters are new and the EGR is OK (also been checked by garage).

It does drive slowly until you try to accelerate and then it dies down and sometimes cuts out.

As far as I can see I'm just left with the fuel pump failing to build pressure?

Any help would be great, Thanks

James
Reply
#2
I think you might be urinating in the wind without the fault codes.

Best you can do is hope you strike lucky changing random parts, but it's not the most cost effective way to fix it.

A cheap code reader would be a better investment than just changing another part.
Reply
#3
Where to start is the problem! Air leak in the fuel line, Fuel pump, blocked tank breather,
clogged injectors.....duff ECU, bad ECU connections, Engine temp. sensor.....
Your cheapest fix will be to find a private repairer who knows what he's doing with a Citroen/Pug
and has Lexia. It's worth a ring round because otherwise you could be chucking £££s down the drain
part changing. Really.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Berlingo won't start 2009...
Last Post:Chri5
Today 12:22 AM
» Replies: 7
» Views: 170
Insurance!
Last Post:fcamp
Yesterday 10:52 PM
» Replies: 6
» Views: 825
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 10:47 PM
» Replies: 2
» Views: 40
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 10:40 PM
» Replies: 0
» Views: 20
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 113
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 31
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 119
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 361
At last
Last Post:Gerald Bostock
Yesterday 08:06 PM
» Replies: 9
» Views: 330
Conversion from manual to...
Last Post:Civvic
Yesterday 07:58 PM
» Replies: 1
» Views: 89

Locations of visitors to this page