Thread Rating:
  • 30 Vote(s) - 2.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fuse box diagram 200 1.9d van ??
#1
hi all newbie here .... bouhgt a 1.9d van 2000 and had no rev or speedo ... thought it was the usual cluster failure so bought another one ... fitted today but still got same problem...
what i need now and isnt in the hayes manual is an actual picture or diagram of both fuse boxes . i think someones been messing about with them .. ive had a fuse tester on them and some are working and some aint ... i know f2 is for the cluster but i need an actual idiot proof pic or diagram of both to make sure all is where it should be ... any help or advice would be gratefully welcome
Reply
#2
(12-03-2012, 05:30 PM)murray Wrote:  hi all newbie here .... bouhgt a 1.d van and had no rev or speedo ... thought it was the usual cluster failure so bought another one ... fitted today but still got same problem...
what i need now and isnt in the hayes manual is an actual picture or diagram of both fuse boxes . i think someones been messing about with them .. ive had a fuse tester on them and some are working and some aint ... i know f2 is for the cluster but i need an actual idiot proof pic or diagram of both to make sure all is where it should be ... any help or advice would be gratefully welcome

Look in How to /guide section http://www.berlingoforum.co.uk/forumdisplay.php?fid=12

In meantime I have attached PDF file Data:Electrical Equipment from the M49 (Mk1) showing both Fusebox`s / Fuse Identification.

If you are removing fuse`s /connections to test, follow the BSI reset procedure to disconnect the battery. Follow this link:

http://www.bba-reman.com/content.aspx?co...ol_failure

What is working on the instrument cluster ?

Can you provide some more info on your motor
Model
Gearbox type
ABS Yes / No
EPS Yes /No
RPO Number this is a five digit number found on a sticker below the `A` post driver side it might be something like 08900
This helps for wiring diagram identification.




Attached Files
.pdf   Data-Electrical Equipment.pdf (Size: 447.63 KB / Downloads: 371)
2003 Citroën Berlingo 2.0HDi Multispace Desire
[+] 3 users say Thank You to BlueBlingo for this post
Reply
#3
thanks m8 . will have a look and give you all the numbers ...
quick details were bought the van last week ... drives like a dream ...
problems when i bought the van were no heater matrix and cluster problem ... van starts 1st time and drives well , all lights, indicators working fine...
instrument cluster problems are on start up only air bag,oil and handbrake light comes on.
fuel gauge is working but temp gauge,rev and speedo isnt..
full beam indicator and light indicator is on when in use ... also the indicator arrows on cluster not working... none of the other lights eg. glow plug etc is working on the cluster ... fitted new cluster unit today but problem persisting ... also when turning ignition off sometimes the stop light comes on and beeps 3 or 4 times then stops ??? will get back tomorrow with all numbers you need etc.. and thanks for taking the time to reply
Reply
#4
Hi, if the matrix has been removed/replaced then it could be a connection problem.
Check you have a good earth on pins 6 & 3 of the speedo unit connector.
If not check the earth point (MC32).
This is located on the passengers footwell inner wing behind the plastic trim. Worth a check?? :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
cheers rustcat ....... been at it again today and cannot get my head round the fusebox may think its from a later model or even a pug
will post pics shortly

anyway the van is a
Berlingo 1.9D 600
variant - MBWJYB
VERSION - M*WJY*

VIN/CHASSIS NO - VF7MBWJYB65626087

here is a pic of fusebox under steering wheel
[img][Image: FUSEBOXBERLINGO.jpg][/img]

and here is one to the right of battery near engine

[Image: ENGINEFUSEBOX.jpg]

:brickwall::brickwall::brickwall:

Reply
#6
found this pic of 1.9d peugoet fuse box


[Image: Phase3fuseboxP.jpg]



says its a phase 3 fusebox .... im totally lost now
Reply
#7
Check fuse 6. :thumbsup:

[Image: 2s6vbxx.png]
2006 2.0hdi 600 with bench seat.  Cool
Reply
#8
doh ... right fuse 6is 5 amp

should i xhange fuses to what the peaugot ones are or keep them as they are ???

Reply
#9
Until you definitely know that the fuses are in the wrong place I would leave them as they are. Confusedtudy:
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Reply
#10
Checked fuses today Changed ones that wernt workin and they still didn't light up on the fuse checker. May have to bite the bullet and get it to the garage Can anyone tell me if there are relays or fuses missing from the engine fuse box from the pic a couple of posts up ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:willpisme
Today 07:48 PM
» Replies: 2
» Views: 23
Poor cold startup 1.9
Last Post:jj9
Today 06:57 PM
» Replies: 23
» Views: 600
Fuel consumption
Last Post:ron
Today 06:28 PM
» Replies: 9
» Views: 196
peugeot charger
Last Post:Johny555
Today 06:06 PM
» Replies: 2
» Views: 53
Washers not working
Last Post:CourierJim
Today 05:38 PM
» Replies: 3
» Views: 49
Anti pollution
Last Post:Caylin46
Today 05:04 PM
» Replies: 5
» Views: 603
Heyup
Last Post:polar
Today 05:03 PM
» Replies: 7
» Views: 301
Amateur radio
Last Post:nicko
Today 04:06 PM
» Replies: 25
» Views: 8256
Apple Carplay
Last Post:Solent
Today 03:58 PM
» Replies: 0
» Views: 18
Haynes manuals - which on...
Last Post:Trevor
Today 03:53 PM
» Replies: 6
» Views: 73

Locations of visitors to this page