Thread Rating:
  • 7 Vote(s) - 3.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Brakes] disk and pads worn in 3k
Hi all

I have a 03 1.9d forte 128000 miles .
My problem started when my disks and pads was changed by my garage after they wore out all was fine for about 3000 miles then i started to get steering shudder when i brake.

(all is fine when the disks are cold no shudder at all )

So i took the car back under the brake warranty they replaced them and it happen again after a few thousand miles so it went back in and this time they used another make of pads and disk but it still happened again.

Now it;s going back in again this weekend for more disks and pads . the garage think there's some other reason there wearing out so quick maybe the calipers any help please

thanks Michael
I once had a Astramax van and the brake servo was faulty and did not release properly , or callipers may be binding
[+] 1 user says Thank You to Willie Fawcett for this post
callipers may be binding as Willie said
[+] 1 user says Thank You to muply for this post
Hi, after you've been out in it, feel the heat coming from the front wheels with the back of your hand. It should only be warm with heavy usage of the brakes.
Also on a low incline or at traffic lights does it roll easy or do you feel it come to a stop??
Once had a caliper stick on a Nova I had, drove it a couple of miles to find there was an orange glow behind the wheel :eek:
Turned out it was a thin layer of corrosion on the top of the caliper piston.
Ok when removed! Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Did they definitely fit different brand brakes or are they just saying so??

On my Mk5 Astra I fitted APEC discs and pads, and after only no more than 1000 miles I had the same issue. Changed them for the same make of disc and pads 3 times, thinking it might of been a bad batch etc, but problem was always there. Shop were 100% certain that there was nothing wrong with their products.

I finally got a pair of ATE discs and used the APEC pads and all problems gone.

Are you getting black pitting on the discs? This could be a sign of impurities in the steel of the brake disc and was the cause of my problem
[+] 1 user says Thank You to 800HDI for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 14
I'm hearing better or smt...
Last Post:andy-M
Today 01:40 PM
» Replies: 9
» Views: 327
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 144
Eco activated but engine ...
Last Post:doofer
Today 01:05 PM
» Replies: 25
» Views: 762
Bump and Run - Am I right...
Last Post:doofer
Today 01:00 PM
» Replies: 16
» Views: 242
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2052
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 142
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 62
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 63
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 32

Locations of visitors to this page