Thread Rating:
  • 7 Vote(s) - 3.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Brakes] disk and pads worn in 3k
#1
Hi all

I have a 03 1.9d forte 128000 miles .
My problem started when my disks and pads was changed by my garage after they wore out all was fine for about 3000 miles then i started to get steering shudder when i brake.

(all is fine when the disks are cold no shudder at all )

So i took the car back under the brake warranty they replaced them and it happen again after a few thousand miles so it went back in and this time they used another make of pads and disk but it still happened again.

Now it;s going back in again this weekend for more disks and pads . the garage think there's some other reason there wearing out so quick maybe the calipers any help please



thanks Michael
Reply
#2
I once had a Astramax van and the brake servo was faulty and did not release properly , or callipers may be binding
[+] 1 user says Thank You to Willie Fawcett for this post
Reply
#3
callipers may be binding as Willie said
[+] 1 user says Thank You to muply for this post
Reply
#4
Hi, after you've been out in it, feel the heat coming from the front wheels with the back of your hand. It should only be warm with heavy usage of the brakes.
Also on a low incline or at traffic lights does it roll easy or do you feel it come to a stop??
Once had a caliper stick on a Nova I had, drove it a couple of miles to find there was an orange glow behind the wheel :eek:
Turned out it was a thin layer of corrosion on the top of the caliper piston.
Ok when removed! Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Reply
#5
Did they definitely fit different brand brakes or are they just saying so??

On my Mk5 Astra I fitted APEC discs and pads, and after only no more than 1000 miles I had the same issue. Changed them for the same make of disc and pads 3 times, thinking it might of been a bad batch etc, but problem was always there. Shop were 100% certain that there was nothing wrong with their products.

I finally got a pair of ATE discs and used the APEC pads and all problems gone.

Are you getting black pitting on the discs? This could be a sign of impurities in the steel of the brake disc and was the cause of my problem
[+] 1 user says Thank You to 800HDI for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold starting. Whats...
Last Post:ron
Today 04:34 PM
» Replies: 4
» Views: 38
Fuel consumption
Last Post:ron
Today 04:30 PM
» Replies: 7
» Views: 118
Lexia clone that works wi...
Last Post:kennard
Today 04:22 PM
» Replies: 60
» Views: 1883
Repair a manual winder wi...
Last Post:cancunia
Today 03:31 PM
» Replies: 1
» Views: 25
lubricating door
Last Post:cancunia
Today 03:25 PM
» Replies: 4
» Views: 110
12v for lighter front
Last Post:cancunia
Today 03:22 PM
» Replies: 18
» Views: 367
1.6 16v petrol cambelt
Last Post:cancunia
Today 03:19 PM
» Replies: 15
» Views: 336
Rear light Cluster
Last Post:Peter Guy
Today 03:13 PM
» Replies: 4
» Views: 101
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 86
"Ultimate" type Diesel fu...
Last Post:ricc
Today 01:56 PM
» Replies: 18
» Views: 474

Locations of visitors to this page