Thread Rating:
  • 10 Vote(s) - 3.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hello everyone.
#1
Hi there everyone,:wave: I have not been on a forum site before so just trying to get to grips with it. Ive just bought a berlingo 1.9 enterprise 2005. I Had a renault kangoo before and had nothing but trouble with it, hand was always in my pocket spening out at garages!:brickwall:, I am really impressed with this belingo such a smooth drive, very quite for a diesel and so spacious. Miles better than the stupid Kangoo. However i have had some worries After a good run it starts to judder at low speeds, and at lights sounds like its going to stall. Also the stop warning light is flashing and the hand brake light stays on too, I have checked all fluid and brake pads they seem ok has anyone and insight, as im not great with engines. Thanks Barry
Reply
#2
Hi bhay2149. Welcome to the Forum.these things are better than a Kangoo. they all seem to suffer from judder at low speed in a high gear, think its the gearing to get max mpg in top etc.
They all seem to suffer from the fuel filter blocking, so if it was me i would replace it which could cure your other problems. its a siemans pump infront of the engine, unscrew the top and pop the filter in, give it a good clean inside with a lint free cloth, there will be bits of brass inside it, make sure you get them all out, these little critters have been known to get through to the injectors and block them, good luck.
Reply
#3
Hi bechstein, appreciate the reply will have a look at the fuel filter today, i assume i cant use any fluids to clean the filter is it just a dry cloth?
Reply
#4
Any idea how to bleed fuel system, because i cleaned the filter put it back and used the pump but just cuts out after few seconds now?
Reply
#5
This will ,no doubt, get the naysayers into orbit,but on my tractor ,an old Massey 135 ,the pump wouldnt prime after a filter change.Theres even a little lever on the side to do it manually but to no avail.
A good long spray of Easy Start down the old buggers' snout while turning the key gave the starter motor a big speed boost.
The pump quickly cleared and your mums' brother was Robert.
No dismantling required.
Its a last resort at the least.....
Reply
#6
ok thanks for your reply, i got it started eventually, just kept priming the pump, but still very juddery at low revs and speed any one any ideas??
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Bottom Ball joint
Last Post:Andyy
Today 08:06 PM
» Replies: 4
» Views: 42
peugeot charger
Last Post:geoff
Today 06:35 PM
» Replies: 4
» Views: 113
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1425
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 789
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 32
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 47
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 37
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 33
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 107

Locations of visitors to this page