Thread Rating:
  • 10 Vote(s) - 3.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hello everyone.
Hi there everyone,:wave: I have not been on a forum site before so just trying to get to grips with it. Ive just bought a berlingo 1.9 enterprise 2005. I Had a renault kangoo before and had nothing but trouble with it, hand was always in my pocket spening out at garages!:brickwall:, I am really impressed with this belingo such a smooth drive, very quite for a diesel and so spacious. Miles better than the stupid Kangoo. However i have had some worries After a good run it starts to judder at low speeds, and at lights sounds like its going to stall. Also the stop warning light is flashing and the hand brake light stays on too, I have checked all fluid and brake pads they seem ok has anyone and insight, as im not great with engines. Thanks Barry
Hi bhay2149. Welcome to the Forum.these things are better than a Kangoo. they all seem to suffer from judder at low speed in a high gear, think its the gearing to get max mpg in top etc.
They all seem to suffer from the fuel filter blocking, so if it was me i would replace it which could cure your other problems. its a siemans pump infront of the engine, unscrew the top and pop the filter in, give it a good clean inside with a lint free cloth, there will be bits of brass inside it, make sure you get them all out, these little critters have been known to get through to the injectors and block them, good luck.
Hi bechstein, appreciate the reply will have a look at the fuel filter today, i assume i cant use any fluids to clean the filter is it just a dry cloth?
Any idea how to bleed fuel system, because i cleaned the filter put it back and used the pump but just cuts out after few seconds now?
This will ,no doubt, get the naysayers into orbit,but on my tractor ,an old Massey 135 ,the pump wouldnt prime after a filter change.Theres even a little lever on the side to do it manually but to no avail.
A good long spray of Easy Start down the old buggers' snout while turning the key gave the starter motor a big speed boost.
The pump quickly cleared and your mums' brother was Robert.
No dismantling required.
Its a last resort at the least.....
ok thanks for your reply, i got it started eventually, just kept priming the pump, but still very juddery at low revs and speed any one any ideas??

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Still on the elusive 4x10...
Last Post:Col
Today 09:05 PM
» Replies: 6
» Views: 176
Bump and Run - Am I right...
Last Post:Opensauce
Today 08:37 PM
» Replies: 20
» Views: 329
I'm hearing better or smt...
Last Post:Johny555
Today 08:31 PM
» Replies: 15
» Views: 386
2012 berlingo radio setti...
Last Post:Jed Clampit
Today 08:29 PM
» Replies: 14
» Views: 353
Newbie checking in
Last Post:Jed Clampit
Today 08:12 PM
» Replies: 2
» Views: 43
Eco activated but engine ...
Last Post:Satellitemark
Today 07:02 PM
» Replies: 30
» Views: 837
DPF Regeneration
Last Post:doofer
Today 06:39 PM
» Replies: 6
» Views: 200
Diagnostic "gear" / Softw...
Last Post:doofer
Today 06:33 PM
» Replies: 11
» Views: 284
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 05:37 PM
» Replies: 2
» Views: 92
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 165

Locations of visitors to this page