Thread Rating:
  • 19 Vote(s) - 3.21 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6hdi camshaft sensor replacement
#1
right. costs about 38 euro for the sensor

its located on the back left of the engine bay, under where the egr outlet meets the inlet manafold.

take out the 2 hex screws holding the egr pipe. you need to bend it out of the way. i stuck a spanner in to keep someway clean. dont go mad its just to give ya room to get a hand down

its held on with one more hex screw. dont disconnect the sensor untill you`v wiggled it out,

same again when putting the new one in, connect it first, stops it falling down if it slips.

get it in position before you screw it down, and make sure its pushed in before final tighten.

screw the egr pipe back. i found it easyer to push it into position first then get a screw started to hold it
Reply
#2
Nicely detailed post. Thanks. But, being very naive about modern autos why did you need to change the camshaft sensor (I didn't even know there was one)?? What symptoms are exhibited by a faulty sensor? Thanks.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
3 times it just shut down, no sputtering or attempt to keep going just stopped.
Wouldn't start until the van shut down completely, (after 5 mins of the key being taken out there's a click noise and everything shuts down)

Then it starts perfect. My thoughts is when the sensor misreads it shuts down the engine to prevent engine damage if it had a camshaft failure and won't restart until the Ecu resets.

I pinned it to the camshaft position sensor with the plug in computer, it showed a saved fault for the sensor[/u]
[+] 1 user says Thank You to corkgsxr for this post
Reply
#4
Thanks for the explanation. I learn something every day.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page