Thread Rating:
  • 5 Vote(s) - 3.6 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio help
Hi all, I have picked up my new berlingo today, and on attempting to swap the standard headunti for my own kenwood bluetooth one I have found a problem. When I turn the ignition off the stereo stays on, even after the dash display shuts off the stereo is still playing away!

Any ideas why or how to sort this out?

Cheers Rob
For how long does it stay on?
At least 5 minutes, haven't sat for too long waiting for it to turn off but obiously need it to go off when getting out and leaving the car.
There are loads of threads about radio settings and plugging in an after market head unit.

Have a search under Radio and there's lots like this:

After lots of reading old posts and a bit of trial and error got the memory working. It's still taking the switched live from the eco live but does shut off after a couple of minutes, will have to remember to take the face off when leaving the car now.

Cheers all.
Mine did that. There is a switched live feed on the iso connector.

I had to pull the proper switch live out and put it where the eco live was.

I think somewhere I posted a reference to which number feed on the iso connector was the proper switched live. On mine, it was wrongly made redundant and the eco live was used, so it needed moving to get it spot on.

I will see if I can find what I did. Otherwise it actually comes live when you open the doors!! If you leave the face on and let it turn off. Get out of the car and leave it, when you return and open the door the head unit kicks in and starts playing!!

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 05:37 PM
» Replies: 2
» Views: 76
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 05:00 PM
» Replies: 4
» Views: 155
Bump and Run - Am I right...
Last Post:Opensauce
Today 03:19 PM
» Replies: 18
» Views: 288
Eco activated but engine ...
Last Post:Satellitemark
Today 02:57 PM
» Replies: 28
» Views: 795
I'm hearing better or smt...
Last Post:Johny555
Today 02:05 PM
» Replies: 10
» Views: 351
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 25
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 153
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2063
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 147
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 70

Locations of visitors to this page