Thread Rating:
  • 5 Vote(s) - 4.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HELP PLEASE - ELECTRICS PROBLEMS
#1
Hi, Can anybody help please. My Berlingo van 1.9 diesel 54 plate has failed the MOT on Horn not working, windscreen washer not working and headlights not showing lit on dashboard..

I have tried changing the Com2000 but no luck, also changed the instrument cluster but same problem. I really dont want to visit the dealers as only just started business with van.

I have seen other posts on here with horn only working with keys out etc but mine doesnt work at all. I have checked all fuses and they are all ok.
Any help would be fantastic, Thanks in advance
lee
Reply
#2
Hi, Have a look at the earth point behind the middle interior light. This is the main earth for the com 2000 module. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
I trust you have reset the BSI?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Heated wing mirrors
Last Post:Bricky Ken
Yesterday 11:57 PM
» Replies: 0
» Views: 15
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 11:07 PM
» Replies: 1
» Views: 81
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 765
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 114
Door locking but unlocked
Last Post:DanielEZY0252
Yesterday 09:45 PM
» Replies: 0
» Views: 11
12v for lighter front
Last Post:Jed Clampit
Yesterday 09:07 PM
» Replies: 8
» Views: 183
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 69
zx1 extralube
Last Post:sks01773
Yesterday 06:07 PM
» Replies: 0
» Views: 42
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 05:57 PM
» Replies: 5
» Views: 133
2012 enterprise berlingo ...
Last Post:Johny555
Yesterday 05:37 PM
» Replies: 9
» Views: 211

Locations of visitors to this page