Thread Rating:
  • 6 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speaker and clock light problems
#1
Hi guys

I am fitting new speakers to the front doors of my 2006 berlingo and haven't got the right connectors so want to just through crimp the cables on and snip the connectors off but I'm not sure on the polarity as the cables aren't well marked.

I also have an issue with the clock on the centre console as it is working but the rear illumination has gone out....is this easily fixed too ?

Any help welcome and thanks for looking
Reply
#2
Have a search on here for your problems there is two threads showing you how to change the bulbs in the display (dead easy) and also on speaker change with all the info you need.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 1 user says Thank You to Tomcat3 for this post
Reply
#3
clock lights simple.just tug the surrounding plastic sort of towards you and up.undo the 2 screws and change bulbs.you cant go wrong.Big Grin
Reply
#4
(25-08-2012, 02:40 PM)Tomcat3 Wrote:  Have a search on here for your problems there is two threads showing you how to change the bulbs in the display (dead easy) and also on speaker change with all the info you need.

I've checked the forum for speakers and they just said make sure they match and take pink as + but not important :-) thanks for the help I'll give it a try

(25-08-2012, 02:41 PM)lorraine Wrote:  clock lights simple.just tug the surrounding plastic sort of towards you and up.undo the 2 screws and change bulbs.you cant go wrong.Big Grin

I'll go and give that a try :-)

Awesome......speakers fitted and working and faulty bulb located too :-)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
12v for lighter front
Last Post:Matija Danko
Today 05:15 PM
» Replies: 19
» Views: 378
Roof noise
Last Post:Veitcast
Today 04:51 PM
» Replies: 4
» Views: 100
Poor cold starting. Whats...
Last Post:ron
Today 04:34 PM
» Replies: 4
» Views: 49
Fuel consumption
Last Post:ron
Today 04:30 PM
» Replies: 7
» Views: 124
Lexia clone that works wi...
Last Post:kennard
Today 04:22 PM
» Replies: 60
» Views: 1898
Repair a manual winder wi...
Last Post:cancunia
Today 03:31 PM
» Replies: 1
» Views: 30
lubricating door
Last Post:cancunia
Today 03:25 PM
» Replies: 4
» Views: 113
1.6 16v petrol cambelt
Last Post:cancunia
Today 03:19 PM
» Replies: 15
» Views: 341
Rear light Cluster
Last Post:Peter Guy
Today 03:13 PM
» Replies: 4
» Views: 102
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 87

Locations of visitors to this page