Thread Rating:
  • 5 Vote(s) - 4.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2003 hdi stereo problem
#1
hi all my name is goose just joined i have a 2003 berlingo 2.0 hdi and need help.i have just changed factory tape deck it has colomn remote and head up display,changed to a new pioneer cd plugged in and nothing so cut wiring and rewired stereo, works fine but head up display sort of works now and then i have no remote and air bag light comes on when i start switch off ign then back on will go out sometimes i have 2 wires not sure what they do and a green wire which i think has something to do with dash not sure so wired it to ign can anyone shed any light please i am lost
Reply
#2
You might have to explain in more detail as I am not sure what you mean is wrong with the display or what you mean by remote?

Firstly there should be no need to cut the wiring as the harness should be an ISO one, but you will probably have to swap over the interchangeable yellow and red wires on the new head unit, as the berlingo has an eco live feed as well as a switched live feed and a permanent live feed.

The sterring wheel controls won't work unless you buy a further adapter and the head unit is compatible.

The display will no longer give you the radio channel info either, when you remove the factory fit unit.
Reply
#3
hi there thanks for reply the car has a colomn remote not on wheel stereo says its compatible i dont know i will try swapping them over and see what happens i guess thats why i am getting the airbag light come on thanks

just a quick one i have wired perm live and ign live fine i am guessing this eco live feed is something else would that be the green wire as that is the one that seems to be linked to gauges and airbag light giving me hassle if so where do i wire that to to get rid of my problems thanks
Reply
#4
As tucker says the wiring should fit without any cutting as it is ISO standard also the display and controls won't work without buying extra adapters/wiring
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2.0 HDi fuel issues as pe...
Last Post:brodfather11
Today 02:05 PM
» Replies: 13
» Views: 217
Haynes manuals - which on...
Last Post:ffrenchie
Today 01:54 PM
» Replies: 4
» Views: 44
Amateur radio
Last Post:ghost123uk
Today 01:41 PM
» Replies: 24
» Views: 8208
peugeot charger
Last Post:grig
Today 01:05 PM
» Replies: 0
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:52 PM
» Replies: 17
» Views: 521
Roof noise
Last Post:Shawks
Today 12:03 PM
» Replies: 6
» Views: 165
Heyup
Last Post:ffrenchie
Today 11:08 AM
» Replies: 6
» Views: 281
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 42
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 180
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 166

Locations of visitors to this page