Thread Rating:
  • 12 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BSI, ECU swap
#1
Hi guys, I would need your opinion on this. Is it possible to take bsi, ecu, fuse box, ignition and central locking from Berlingo van 1,9d 2004 and use it on my 1,9d 2003 Multispace? Or does it have to be exactly the same model?
Reply
#2
Why do you need to do this? What is the problem with the 2003 car?
I think aside from the obvious, the running gear will be the same and the ages
of both are close enough for no major differences. Hell of a job though.
If Rustcrat comes by perhaps he can have a quick look at the circuits of both
and tell you of any important differences.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#3
Thanks for taking an interest Ol'Jeffers. Well its basically this. Ever since I bought the car management light was on while driving, which is nothing unusual, but when I stop and turn off ignition (key out) all ignitions lights comes on and stays on for some period of time, in this mode nothing works. Only way to get it out quickly from this mode is to press and hold brake pedal for few seconds or lock car manually, sometimes help to press hazards. To add to the problem red STOP light started to flash on dash recently + another few lights are permanently on. While this is happening I have no wipers and most of the time no indicators. What else? …..oh speedo and fuel gauge are out too. I know I could send my bsi unit to be virginised, but then it needs to be reprogrammed back to the car and I don’t know anyone who would do it for me. There for I was looking for other solution to solve this annoying problem.
Reply
#4
I had some very similar problems to this mate, and it turned out to be a damaged BSI unit........ I too considered replacing BSI, ECU, Ignition etc. But in the end I didn't have to! I'm not saying he will, but I sent my BSI unit up to Rustscrat and he repaired it for me, now it's as good as new............ Just an option, but Rustscrat is definitely your man!
Reply
#5
Thanks for the tip LloydyBoy. I do have a strong feeling that this is BSI. Did you have to reprogram your unit after repair or was it just the case of "plug and play"?
Reply
#6
Hi mate....... If the damaged BSI can be repaired there should be no need to virginise it! When I got mine back it was a case of plugging it in and away you go!!!!! Didn't even have to do a BSI reset......... I thought mine was absolutely knackered to be honest! I had no speedo, revcounter, fuel gauge, temp gauge etc. and also a flashing cluster of lights on the dash for 9 months. All the functions on the van worked fine and it drove fine as well so don't lose the faith mate............ Rustscrat is the BSI Daddy!!!!!
Reply
#7
(14-09-2012, 07:07 AM)LloydyBoy Wrote:  Hi mate....... If the damaged BSI can be repaired there should be no need to virginise it! When I got mine back it was a case of plugging it in and away you go!!!!! Didn't even have to do a BSI reset......... I thought mine was absolutely knackered to be honest! I had no speedo, revcounter, fuel gauge, temp gauge etc. and also a flashing cluster of lights on the dash for 9 months. All the functions on the van worked fine and it drove fine as well so don't lose the faith mate............ Rustscrat is the BSI Daddy!!!!!

Hi mate, I hope you right. I'm trying not to lose my faith, but sometimes it's hard. :S
Reply
#8
(14-09-2012, 08:11 PM)horinkova Wrote:  
(14-09-2012, 07:07 AM)LloydyBoy Wrote:  Hi mate....... If the damaged BSI can be repaired there should be no need to virginise it! When I got mine back it was a case of plugging it in and away you go!!!!! Didn't even have to do a BSI reset......... I thought mine was absolutely knackered to be honest! I had no speedo, revcounter, fuel gauge, temp gauge etc. and also a flashing cluster of lights on the dash for 9 months. All the functions on the van worked fine and it drove fine as well so don't lose the faith mate............ Rustscrat is the BSI Daddy!!!!!

Hi mate, I hope you right. I'm trying not to lose my faith, but sometimes it's hard. :S

OK, I bought secondhand BSI,ECU unit, ignition barrel and the key. Was given VIN code of the vehicle and was told that it had around 80 000ml . I think you know where I am getting with this. Now I have 235 000ml on the clock instead of my original 122 000ml and I couldn’t get the thing started anyway. What an old fool I am. I didn’t have much time to play with it, just plugged new BSI and ECU in, then slit plastic receiver from original barrel and tape new key to it in attempt to trick immobiliser and used my original key to crank ignition. Engine was turning but wouldn’t start. Either I am missing something or new key is not coded to BSI.
Reply
#9
(16-09-2012, 09:17 PM)horinkova Wrote:  
(14-09-2012, 08:11 PM)horinkova Wrote:  
(14-09-2012, 07:07 AM)LloydyBoy Wrote:  Hi mate....... If the damaged BSI can be repaired there should be no need to virginise it! When I got mine back it was a case of plugging it in and away you go!!!!! Didn't even have to do a BSI reset......... I thought mine was absolutely knackered to be honest! I had no speedo, revcounter, fuel gauge, temp gauge etc. and also a flashing cluster of lights on the dash for 9 months. All the functions on the van worked fine and it drove fine as well so don't lose the faith mate............ Rustscrat is the BSI Daddy!!!!!

Hi mate, I hope you right. I'm trying not to lose my faith, but sometimes it's hard. :S

OK, I bought secondhand BSI,ECU unit, ignition barrel and the key. Was given VIN code of the vehicle and was told that it had around 80 000ml . I think you know where I am getting with this. Now I have 235 000ml on the clock instead of my original 122 000ml and I couldn’t get the thing started anyway. What an old fool I am. I didn’t have much time to play with it, just plugged new BSI and ECU in, then slit plastic receiver from original barrel and tape new key to it in attempt to trick immobiliser and used my original key to crank ignition. Engine was turning but wouldn’t start. Either I am missing something or new key is not coded to BSI.

PM sent.
2006 2.0hdi 600 with bench seat.  Cool
Reply
#10
I'm afraid to say mate that I think you may have wasted your money. Unfortunately It's not quite as easy as swapping the BSI, ECU, Ignition etc over and away you go. Honestly mate, the best thing to do is to get the original BSI repaired, trust me, I'm speaking from 'painful' experience.......... I see Rustscrat has PM'd you, so hopefully he'll put you right.............. Good Luck mate, chin up!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 17
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 88
2012 enterprise berlingo ...
Last Post:Col
Today 05:01 PM
» Replies: 4
» Views: 82
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1774
Water Heater - Glow Plug ...
Last Post:jj9
Today 04:30 PM
» Replies: 19
» Views: 518
Head gasket failure.
Last Post:david.mckay.3760
Today 04:28 PM
» Replies: 12
» Views: 312
Eco mode
Last Post:ghost123uk
Today 04:28 PM
» Replies: 21
» Views: 13756
2025 Diesel Ban
Last Post:dumdum
Today 02:46 PM
» Replies: 1
» Views: 44
Berlingo won't start 2009...
Last Post:Col
Today 01:49 PM
» Replies: 6
» Views: 142
Facial light replacement
Last Post:peteh80
Today 12:35 PM
» Replies: 5
» Views: 171

Locations of visitors to this page