Thread Rating:
  • 8 Vote(s) - 2.63 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New indicator switch
#1
I’ve just ordered a comm2000 for my Berlingo van. I did a search on the forum and found some good advice on fitting, but my Haynes manual says that it must be fitted by a dealer as it has to be coded to the BSI. None of the posts mention coding to the BSI, but as this is a new unit and not second hand, would this make a difference?
I did find a comm2000 reset procedure, would this do the trick?
Thanks in advance guys.
Reply
#2
Hi, as far as I can tell the unit it's self won't need programming as long as it's a like for like unit. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
[+] 2 users say Thank You to Rustscrat for this post
Reply
#3
It may need coding. My Partner had a replacement comm2000 recently before I bought it & was incorrectly configured as my front foglights wouldn't switch on. Once the specialist plugged the PP2000 into it & configured it correctly it was all good again. If it was a simple case of plug it in & all works, I wouldn't have thought mine would have been configured at all, let alone incorrectly.
2000/X Peugeot 406 110 HDi LX Family 93k to 2000/W BMW 530D SE Auto 84k to 2003/03 Peugeot Partner Escapade 95k

Standard so far

[Image: Signature.jpg]
[+] 1 user says Thank You to waue1978 for this post
Reply
#4
Mine didn't need coding.

Sent from my ST21i using Tapatalk 2
How much is the fish?
[+] 1 user says Thank You to knobblywobbly for this post
Reply
#5
Pretty sure the fogs, cruise control etc are all configured in the Bsi and as you're not changing this you should be ok.:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Reply
#6
Thanks guys, I feel a bit more confident in changing it now. But I've got the phone number of a local specialist in case it doesn't work.
I'll update the post as soon as I get it on (weekend I hope) so that future Berlingo newbies, like me, can see the results when searching.
Reply
#7
Got the com2000 changed without major problem and everything worked OK except the screen washers. But then they didn't work before so I guess a new pump is in order as I can't hear the pump and disconnecting the pipe also produces no water.
I did take about half hour unclipping the steering wheel airbag, through three little holes in the back of the steering wheel. Each time I got to the last one the others clicked back into place, but got there in the end with a few screwdrivers wedged in the slot.
Also radio didn't need a code despite the battery being off for an hour, so good news alround.
Reply
#8
Don't think me rude but what does the com2000 cost ? Hopefully I never need one. P.S well done on a good result !
Reply
#9
Hi, what will you be doing with your old unit as I'm looking for parts for a test rig. :drool:
:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#10
Geoff; Comm2000 cost me in the region of 130.

compdoc; lack of screenwash motor operation could also be the fuse. My handbook mentions fuse location if my memory serves me. You may get both the fuse and the motor kaput in the same instance.
[+] 1 user says Thank You to CaptainKirk for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 149
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 49
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 23
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 280
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 83
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 77
Bottom Ball joint
Last Post:Andyy
Yesterday 08:26 PM
» Replies: 6
» Views: 89
cutting out HDi 1.6 diese...
Last Post:Col
Yesterday 06:15 PM
» Replies: 18
» Views: 1447
Poor cold startup 1.9
Last Post:Top drive
Yesterday 06:10 PM
» Replies: 34
» Views: 812
starting problem
Last Post:brodfather11
Yesterday 03:32 PM
» Replies: 1
» Views: 46

Locations of visitors to this page