Thread Rating:
  • 4 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery V Alternator......
#1
Hi fellow Berlingolians...... Having an electrical issue with my 98, 1.8d 600d van, all was good yesterday but today the battery light on the dash came on but very very faint, you could only just see it, did 50 miles, then went to start and the battery was dead, managed to jump start it, and battery light stayed off for the first few min then came on again, AA man sayed the battery was shot, but was this just a sales pitch to get me to buy a new battery ? Anyone else had this prob, is it not a faulty alternator ? Any help appreciated, cheers guys.
Reply
#2
Surely the answer is to have the battery & alternator tested.If the voltage drops too low,the alternator field windings will not be excited,& no generation will take place.The generator light goes out when batt volts match alt volts.An erratic light is usually bad connections/regulation,or loose belt.
Get it checked & let us know how you get on.Good luck.
Strawberry flavoured windows  Dodgy
Reply
#3
Thanks, yeah I had the AA guy test it, before starting the meter showed 12.48 v but it wouldn't even turn over, once jump started like I say the batt light stayed off and it was showing 14.8 v he said alt was working but after he'd gone the alt light came on still only just faint enough to see, did my 50 miles home and the batt is completely dead, worth just changing the battery first then if still doing it the alt ??
Thanks, mart.
Reply
#4
Hi, I once drove home from Carlisle to Leeds with alternator lamp lit all the way back. In other words I was running on batt. power. This was with lights on as well. Turned out it was the brushes that had worn out in alternator.
I'd start with checking your connections like Ron said especially the main pos. connection from your batt. to the starter motor & alternator + the main earth from batt. to engine. If all ok, I'd go for new battery before the alternator. You could always borrow a battery from some one to check first.
:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
From the dim battery light coming on and the subsequent drive of 50 miles I'd say it is likely the the brushes in the alternator need looking at / replacement.

It is never worth " just changing the battery first then if still doing it the alt ?? " as you are likely to be throwing money away. Always but always undertake the basic diagnostic checks first before spending any money, many checks / tests are simple or even free.
Reply
#6
Ive had batteries that broke down gradually giving an intermittent fault-they'd be fine one day then completely dead the next-
When you are averse to spending money its a difficult hurdle.
And the battery should be at around 14.4v.
Twelve volts indicates an unhealthy or discharged condition.
Our local independant auto electrician is Snowden -they are really decent(an appreciate the benefit of return custom)so will test things properly and give good advice.I bought a big tractor battery from them once and they still checked and deep recovered it well out of its warranty period
Id get an expert opinion
Reply
#7
Thanks evryone for your comments, Ive swapped the battery with a family members 2 month old battery from his van and the batt light on the dash is still on which is making me think that yes the bushes in the alt has worn and not doing the job, does anyone know if this alt is compatible with any other car or van, I know someone who has a couple of citroen/pug's in his yard and says i could have a look.......

Thanks.
Reply
#8
Thanks to everyone, I had it tested and the alt was showing as faulty, managed to get a recon one and swapped it over, problem solved, good old mk1 running sweet again. Smile
[+] 1 user says Thank You to Driver33 for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 05:31 PM
» Replies: 3
» Views: 51
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 558
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 76
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 83
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 354
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 872
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 68
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 177
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 59
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 45

Locations of visitors to this page