Thread Rating:
  • 12 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp gauge flicks and stop light flashes
#1
I have a berlingo van 2002 just had new engine fitted now I have another problem the temp gauge flicks Frm cold to hot and the stop light bleeps and flashes any ideas thanks
Reply
#2
When that happened on my old 2.0 HDI it was it was the temperature sensor in the thermostat housing.
Reply
#3
Were is that is it the green plug wid the 2 wires
Reply
#4
Yes Green since RP0 09156. Item 9 on the attachment, which has a clip 11 which holds it in & an O ring to seal it.

I think I just removed it & quickly used a rag to seal the hole & then put the new one in, an extra pair of hands is useful.


.pdf   BERLINGO - 0400 06 236099A - OUTLET TANK SWITCH PROBE.pdf (Size: 79.13 KB / Downloads: 55)
Reply
#5
above tried not solved the problem all wires checked coolant level sensor checked problem still persits had 4 differnt mechanics now and been plugged into machine still not fixed i just dont fancy given citreon £71 per hour any more sugestions welcom
Reply
#6
(14-10-2012, 04:42 PM)Steve maryport Wrote:  above tried not solved the problem all wires checked coolant level sensor checked problem still persits had 4 differnt mechanics now and been plugged into machine still not fixed i just dont fancy given citreon £71 per hour any more sugestions welcom

I am not going to be of much more help than tc_1 because my experience is similar. Tell us a bit more - it is a 2.0hdi?, is the fan operational? does the fan come on when the green temp sensor is disconnected? does the red STOP light come on and the temp guage shoot up at the same time? what are the other mechanics saying? are there any independent Citroen garages in your area that you have gone to?

Hope that somebody else give you answers, instead of questions like me.
Reply
#7
there all puzzeld the stop light and temp gauge flash at same time its 1.9 d and yeah the fan does work when unplugged they just saying electrical fault of some sort as they tested everything and everything working fine
Reply
#8
just thought i would say i had same problem stop light coming on and temp gauge shooting to top and down again it turned out it was the fan switch fault not paying £173.00 thats what citreon wanted as you have to buy the whole harness ect so i just put a manual switch in and keep an eye on it van i have got is 2003 hdi.
Reply
#9
I've got same problem now, but mine's stuck on with temp at full and fan constant! Gonna check the fan switch out though if you say that's what the problem was on yours!
Reply
#10
Hi there
see http://www.berlingoforum.co.uk/showthread.php?tid=8044
I have the same problem. I asked to day at my local car shop, and they said change the cooler liquid sensor and all will be ok.
I will change it tomorrow as i pick it up then
My Car INFO:
CITROËN BERLINGO (MF) 1.4 i (MFKFX, MFKFW)
2005 Mod
Volum: 1360 KW: 55 HK: 75 Fuel: Gasoline
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
12v for lighter front
Last Post:cancunia
Today 10:35 AM
» Replies: 15
» Views: 321
how many miles on yours ?
Last Post:Wyvern
Today 10:27 AM
» Replies: 18
» Views: 808
Roof noise
Last Post:Opensauce
Today 09:59 AM
» Replies: 2
» Views: 67
Rear light Cluster
Last Post:Opensauce
Today 09:50 AM
» Replies: 3
» Views: 87
Saying Hello
Last Post:ghost123uk
Today 09:07 AM
» Replies: 2
» Views: 46
lubricating door
Last Post:brajomobil
Today 08:05 AM
» Replies: 2
» Views: 87
Lexia clone that works wi...
Last Post:brajomobil
Today 08:02 AM
» Replies: 59
» Views: 1862
Heated wing mirrors
Last Post:3rensho
Today 04:30 AM
» Replies: 4
» Views: 127
1.6 16v petrol cambelt
Last Post:cancunia
Yesterday 11:59 PM
» Replies: 13
» Views: 312
Ncb help
Last Post:Jed Clampit
Yesterday 10:32 PM
» Replies: 5
» Views: 162

Locations of visitors to this page