Thread Rating:
  • 7 Vote(s) - 3.57 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] engine will not restart for approx 5 hours
#1
I am trying to sort out a colleagues fault on his 03 1.9 hdi with a siemens 801A common rail, its a shaggy dog story so please bear with me.
The vehicle was bought with the fault and driven from birmingham to Cornwall with no issues.
The fault is that the engine will start from cold ok but once the engine has run, even for a matter of seconds it will not restart for approx 5 hours, when he collected the vehicle he left it running whilst refueling so no problem but once home he switched off and it would not restart.
I have carried out a pin to pin continuity test on the engine to ecu the wiring is all ok the connectors are in good condition and both the cam and crank sensors have been replaced with new ones. The injectors have been replaced due to out of limit leakback with good ones that have been checked for leakback - within spec. The HP pump has been tested using a blind pressure tool - 1350 bar so all is ok there. Using a dual trace scope cam, crank, rail, hp pump volume and pressure sensors and peizo injectors are showing ok. Rail pressure rises fast when cranking and when the fault is present it is only the injector pulse that is missing. Performance and economy is good with no smoke present at all. I then was guided down the ecu route by a contact that felt it was getting into a loop that prevented a restart, however I am beginning to suspect that its perhaps the immobiliser that is the root cause but I cannot find a wiring diagram showing how the ecu is connected to the immobiliser - which pins and when etc. Any advice will be gratefully recieved.
Reply
#2
Hi, the engine Ecu comms with the Bsi which checks the key for the right code etc.
The best way to diagnose this would be to find someone with Lexia and get a read see if the Ecu is locking out. (immobilized)
Apart from that, it could be a heat related problem but if it's always approx 5 hours then it's unlikely.
Have you tried a Bsi reset?

http://www.bba-reman.com/content.aspx?co...ot_process

Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
Thank you for the reply, yes I have reset the BSI and followed the battery shut down and wake up procedure on a number of occasions. Are you aware of the circuitry to the ecu? I feel sure that a supply or earth is being lost and preventing the ecu to go into it`s run mode, this seems to be possible as the ecu only isolates the injectors when engine shut down is initiated, with the rail pressure being reduced by the hp pump valves once the engine has stopped.
I know it`s a long shot but if I could just get a wiring diagram even if it proves me wrong then I would feel I was getting somewhere.

Thanks again for your assistance Rustscrat
Reply
#4
(26-09-2012, 04:03 PM)ian Wrote:  Thank you for the reply, yes I have reset the BSI and followed the battery shut down and wake up procedure on a number of occasions. Are you aware of the circuitry to the ecu? I feel sure that a supply or earth is being lost and preventing the ecu to go into it`s run mode, this seems to be possible as the ecu only isolates the injectors when engine shut down is initiated, with the rail pressure being reduced by the hp pump valves once the engine has stopped.
I know it`s a long shot but if I could just get a wiring diagram even if it proves me wrong then I would feel I was getting somewhere.

Thanks again for your assistance Rustscrat
If you can PM me your vin No. I'll dig out the correct ones.Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
Good afternoon Rustscrat

The vin is VF7GJRHYK93080232

If you can assist me with a diagram and/or connector pinouts I would be most grateful

Regards

Ian
Reply
#6
Are these any good to you?
Let us know how you get on. Confusedalut:

[Image: 2im12rn.png]

[Image: 30i7xc2.png]
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
Good morning Rustscrat
Yes, this is exactly what I was seeking, do you perhaps have the unit identifications too as some items are not so obvious to me from the diagram

Thanks again

Ian
Reply
#8
(28-09-2012, 09:58 AM)ian Wrote:  Good morning Rustscrat
Yes, this is exactly what I was seeking, do you perhaps have the unit identifications too as some items are not so obvious to me from the diagram

Thanks again

Ian

I don't have a list as such but if you can list the item No's I'll identify them for you. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
hi there did you ever get to the bottom of this problem?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1413
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 773
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 25
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 43
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 34
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 32
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 102
peugeot charger
Last Post:3rensho
Today 06:46 AM
» Replies: 3
» Views: 103
Aftermarket radio stalk C...
Last Post:Matt Haigh
Yesterday 11:53 PM
» Replies: 7
» Views: 268

Locations of visitors to this page