Thread Rating:
  • 6 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mk1 berlingo
#1
Hi to all at the forum this is my first post here my question is this, i have a 2000 Berlingo multispace and the instrument cluster has started to go haywire the fuel gauge slowly goes from full or half full to empty also the temperature gauge bounces from hot to cold constantly while driving and last but not least the digital display reads 10000 service due even though the service indicator has been reset(so i cannot read my mileage). Please help. thank you.
Reply
#2
Hi Bob and welcome to the forum.

Have a look in the "Problems & Faults" area and I am sure that you will find some useful info there.
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


[+] 1 user says Thank You to Chris for this post
Reply
#3
Hello to you.

As Chris says, also try a search.
[+] 1 user says Thank You to Coco for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2025 Diesel Ban
Last Post:polar
Today 03:05 PM
» Replies: 14
» Views: 281
Lexia clone that works wi...
Last Post:kennard
Today 02:59 PM
» Replies: 58
» Views: 1827
1.6 16v petrol cambelt
Last Post:cancunia
Today 02:39 PM
» Replies: 10
» Views: 191
Insurance!
Last Post:Opensauce
Today 01:52 PM
» Replies: 10
» Views: 905
12v for lighter front
Last Post:ghost123uk
Today 01:39 PM
» Replies: 13
» Views: 263
Door locking but unlocked
Last Post:ffrenchie
Today 10:17 AM
» Replies: 3
» Views: 59
Rear seats
Last Post:doofer
Today 09:55 AM
» Replies: 1
» Views: 75
1.6 hdi 90bhp Turbo and i...
Last Post:Trevor
Today 09:46 AM
» Replies: 2
» Views: 108
lubricating door
Last Post:sks01773
Today 08:57 AM
» Replies: 0
» Views: 42
Heated wing mirrors
Last Post:3rensho
Today 06:00 AM
» Replies: 1
» Views: 53

Locations of visitors to this page