Thread Rating:
  • 5 Vote(s) - 2.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oh No!
#1
HI All,
After over a week of trouble free motoring when it was difficult to find fault with my 03 1.9 Multispace,my stomach sank while doing my first weekly fluid checkSad.Opening the coolant reservoir cap I was confronted by thick black oil in the coolant.There doesnt seem to be any water in the oil,and the exhaust is perfectly clear.Ill take it to the garage I bought it from tomorrow,hopefully its just a oil cooler problem.:eek: Very disappointing.
Reply
#2
Sorry to hear that. Just be firm with the garage.
[+] 1 user says Thank You to Coco for this post
Reply
#3
What oil cooler? As Coco says, stand your ground with the garage. I hope it isn't anything too serious.
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
[+] 1 user says Thank You to crickleymal for this post
Reply
#4
Isent the oil cooler between the oil filter and the block? I assume my engine has one as two water pipes go into the oil filter housing and they gargle the header tank when sqeezed.
Les.
Reply
#5
Think you are right on this one Les.... Not a oil/Air cooler but an oil/Water cooler...
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
[+] 1 user says Thank You to andy-womble for this post
Reply
#6
Went to see my machanic this morning(well yesterday morning now)and when I told him about the oil in the expansion tank he dismissed it.He said 'Oh that will clear,oil was getting into the water thats why I changed the head and radiator'.He took a rag and wiped the oil off the surface of the coolant.Admittedly it looked a lot worse than it was, only a few mm,s thick.I dont know why he dident tell me to expect it instead of letting me make a fool of myself.Anyway I syphoned the header tank a couple of times myself and put in a litre of fresh coolant and all seems clear now(apart from a few rainbow streaks) even after a trip Moffat and a 75mph return journey via the A74M motorway.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 133
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 44
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 18
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 276
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 80
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 73
Bottom Ball joint
Last Post:Andyy
Yesterday 08:26 PM
» Replies: 6
» Views: 84
cutting out HDi 1.6 diese...
Last Post:Col
Yesterday 06:15 PM
» Replies: 18
» Views: 1437
Poor cold startup 1.9
Last Post:Top drive
Yesterday 06:10 PM
» Replies: 34
» Views: 810
starting problem
Last Post:brodfather11
Yesterday 03:32 PM
» Replies: 1
» Views: 45

Locations of visitors to this page