Thread Rating:
  • 22 Vote(s) - 2.91 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Front suspension top mounts
I know that this has been covered in depth on a previous post, but wanted to double check before ordering the parts. My 58 plate XTR has the dreaded top mount cluncking problem. I have contacted an online citroen parts supplier and asked for a quote for the upgraded parts required as described in previous post by jonnyboy (503375 & 5038f7)

The supplier stated that these parts were not stated for my vehicle and could not accept any returns.
Are these the upgraded parts that I need ?
Result, went to my local Citroen Dealer (Llangefni Anglesey) on the weekend and asked the service tech about the mounts. He confirmed that there is a modified / updated top mounts available. Ordered both sides cost £67. Will update with the outcome after fitting them. Fingers crossed
hI AND HELLO, AS FOR LLANGEFNI, I wouldnt trust them one inch after all my problems and bullshit given me over last few years. Thinking of going all way to Abegele for 3rd and final free service. Maybe if your welsh???? you might get better treatment? Keep me informed.
what colour is your berlingo?
I am silver with extra bits as you can see from photo? and my reg is pch. so flash if you see me.
2010 artic silver VTR with EXTRAS.......Confusedunny:
Had the top mounts replaced yesterday by my friend who owns a local garage, so far the metalic clunking noise has gone, still some rattle when going over bumps sounds like anti roll bar bushes maybe.
But all in all happy with the outcome. Will see if the noise re appears or not.
Pete: Have a silver 58 plate XTR - Will keep an eye out for u.
Good to know you hopefully have a result Pete .my 2009 model is in the garage 15th of this month for tattling noise at front & banging and a sensation of moving sideways from the back end ! Hopefully I will get a result too .
moving sideways, if on a bump when turning I believe is just a symptom of this type of rear axle end.Not mechanicval, but sure techy guys will confirm.Pete
2010 artic silver VTR with EXTRAS.......Confusedunny:
Hmmm. Interesting. My 2009 model does both these things. Thumps a bit on the nearside over bumps and is a bit wobbly at the rear. For now I had just put it down to the type of vehicle, but it did remind me of various Fords I used to own where I'd regularly have to replace bits of suspension to keep them sharp.
Unlike the Mk.2 Berlingo, the Mk.3 doesn't have independent rear suspension.
The rear has IIRC a beam axle(??) so the rear wheels are physically linked.
Gimme independent anytime....arms, struts whatever!!
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Really?! Wow. That's a bit old school. Ah well, fair enough then - that'd certainly explain it. I'll stop worrying and slow down.
money money money....I guess, cheaper to manufacure maybe.
2010 artic silver VTR with EXTRAS.......Confusedunny:

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Bump and Run - Am I right...
Last Post:Opensauce
Today 03:19 PM
» Replies: 18
» Views: 277
Eco activated but engine ...
Last Post:Satellitemark
Today 02:57 PM
» Replies: 28
» Views: 783
I'm hearing better or smt...
Last Post:Johny555
Today 02:05 PM
» Replies: 10
» Views: 347
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 18
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 147
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2061
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 144
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 68
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 69
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 37

Locations of visitors to this page