Thread Rating:
  • 13 Vote(s) - 2.31 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lexia help please - Airbag lights
#1
Well alright, it's Planet really but now I've got your attention...

I splashed out and bought a clone of Planet (Lexia). All connected and working O.K.

1) I'm trying to clear the airbag lights but can't, I get the following:
Airbag ECU = "Permanent fault VAN network" - "Passenger airbag deactivation"
I've removed and remade the connections under the seats and removed cleaned and replaced the deactivation switch at the side of the dash, all to no avail. I've taken out and cleaned the airbag ECU and checked it's earths which were good.

2) It also shows on the BSI "Permanent fault communicating on the DATA wire with the engine wiring housing"
I've taken out and replaced the BSI, all connections were good and all fuses intact.

3) Whether this is related or not, I also have a fault code 0483. I think that this relates to the cooling fan, which I have yet to explore

Any ideas please??? :brickwall:
[+] 1 user says Thank You to Coco for this post
Reply
#2
The "engine wiring housing" will be the engine bay fuse box(Bsf).
Both these units (a,bag ecu & Bsf) use the same Comms and are both fed off the same Comms fuse - No. 14 in the Bsi.
Whilst poking around the Bsi, check for water damage or coffee etc.
I've had three of these units now all with comm faults due to liquid Confusedillyme:
Does the reader say "Data A" or "Data B" maybe?
Let us know how you get on. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
[+] 3 users say Thank You to Rustscrat for this post
Reply
#3
Thanks, I was hoping you'd turn up !

I've not had the plastic cover off the BSI yet, but there was no sign of water contamination anywhere - I'll have to look further.

No mention of Data A or B, just "DATA wire". Hope to have half an hour to have another go at this tomorrow morning, I'll keep you posted.
Reply
#4
Well the BSI shows no signs of any fluid ever being near it, completely unmarked.

All fuses good, also all engine bay fuses good. No 14 on the BSI changed just for good measure.

On restarting no change, still have two airbag lights. I can't hook up Planet because the diagnostic socket has disappeared !!! It's come adrift from the plastic trim and I don't have time to dismantle half the dash to find it before going to work. Job for tomorrow then !
Reply
#5
(17-10-2012, 09:15 AM)Coco Wrote:  Well the BSI shows no signs of any fluid ever being near it, completely unmarked.

All fuses good, also all engine bay fuses good. No 14 on the BSI changed just for good measure.

On restarting no change, still have two airbag lights. I can't hook up Planet because the diagnostic socket has disappeared !!! It's come adrift from the plastic trim and I don't have time to dismantle half the dash to find it before going to work. Job for tomorrow then !

Same happend with mine, I managed to get my hand round the back and push it back in! :whistle:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Coco, just been trying to simulate your faults on my test rig and found that if the Bsf has data problems it brings up the air bag fault. Not saying it's the same for yours as this is a different engine (DW8B) but air bag won't clear until the Comms are sorted.
Did you notice any faults with the "controls under the steering wheel" ?
Confusedcratch:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
No, all column mounted controls work as they should. Going out to have another go in a minute (after changing the power steering fluid) so I'll report back later.
Reply
#8
Tried again and still no joy.

Tested the Comm 2000 and no faults found. The others remain as they were before.
Reply
#9
Check the 10 pin connector "EP1" in the engine fuse box, check for corrosion etc. Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#10
Just been having another play and found out that your air bag fault translates to this - "There is a fault on the Van network. The passengers air bag has been deactivated."
So I think the fault lies with the Comms to the engine fuse box (Bsf) on your "data" wire (9012 red, pin 1 EP1(10v NR) Bsf, pin 6 EP(40v NR) Bsi).
Confusedalut:

.pdf   dw10 air bags.pdf (Size: 162.85 KB / Downloads: 146)
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Head gasket failure.
Last Post:Civvic
Today 08:08 PM
» Replies: 13
» Views: 330
At last
Last Post:Gerald Bostock
Today 08:06 PM
» Replies: 9
» Views: 299
Conversion from manual to...
Last Post:Civvic
Today 07:58 PM
» Replies: 1
» Views: 71
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 34
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 94
2012 enterprise berlingo ...
Last Post:Col
Today 05:01 PM
» Replies: 4
» Views: 89
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1777
Water Heater - Glow Plug ...
Last Post:jj9
Today 04:30 PM
» Replies: 19
» Views: 530
Eco mode
Last Post:ghost123uk
Today 04:28 PM
» Replies: 21
» Views: 13772
2025 Diesel Ban
Last Post:dumdum
Today 02:46 PM
» Replies: 1
» Views: 49

Locations of visitors to this page