Thread Rating:
  • 11 Vote(s) - 2.73 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.9d yr2000 no instrument panel,indicators
#1
Hi I have a yr 2000 1.9d ,no instrument panel at all,no indicators,no wipers some times no heater.working interior lights,front,rear lights,brake lights,hazard switch and lights.on dash ,handbrake light,engine light but goes out once engine started,horn,washer jets.van starts fine any help appreciated.
Reply
#2
Hi, If you can PM me your Vin No. I'll have a look through the drawings for your van. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
I had this on my 1st lingo 1.9 2000 it was a 5amp fuse I cant remember the number but it does the instrument panel warning lights (not bad I hear you say) but with these out, I had no wipers/indicators/leccy windows and a host of other things, but this did not stop the engine from running OK. never managed to bottom out what caused it to blow before the aux belt problem caused the timing belt to jump writing off the engine.
Reply
#4
Hi checked all fuses, reset bsi 7 times and still nothing
I will send u my vin .many thanks
Reply
#5
A few questions, do the indicators actually work on the outside?
Does the interior light come on when you open the door?
Does the dash illuminate when side lights switched on?
When the hazards are on do you get the green arrows on the dash?
Does the clock work.
Do the temp & petrol guage work?
Confusedcratch:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Interior light comes on when switched , not a thing on dash except to let me no side lights are on, and when they are on hazard switch illiuminates other than that nothing else works.

Also I don't have fob on key just key so assume no immobiliser but took bsi out and it has written on it all ok ?? Also under passenger seat two bsi with not working ?? So it has been replaced before.
Reply
#7
I'm wondering if the existing BSI has been correctly coded to the vehicle,
assuming it was like that when you got it.
KEEP the extra BSIs they can be repaired at fraction of the cost of new ones.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#8
Noticed earth terminal on battery little loose so thought I would tighten it, snap and in half it now is.ill buy some new terminals and may be was getting a good enough earth??
Reply
#9
Good move!! But if your car started OK then I doubt that it's the cause.
Make sure when you change the terminal that use follow the full BSI re-set procedure.
Here it is: http://www.bba-reman.com/content.aspx?co...ol_failure
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#10
hi just a bit of a update,took bsi out of car and used the one that i found that said dash ok immobilser not sync so swapped them around and dash worked,window wipers but no indicators and not starting but expected the not starting,so swapped back.So it looks like i will need bsi checked out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 05:31 PM
» Replies: 3
» Views: 49
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 558
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 76
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 83
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 354
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 872
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 67
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 177
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 59
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 43

Locations of visitors to this page