Thread Rating:
  • 6 Vote(s) - 2.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi new owner needs help.
#1
Hi ya, just purchased a berlingo 2.0 hdi van on a y plate. When I got it drove it home fine without any issues, today took it to work put £20 worth of fuel in just over quarter on gauge drove few miles gauge drops loads. Got to work ok didn't think to much about it till went out again and pulling onto motorway building revs up engine management light comes on and shuts down engine.

Restarts fine drives ok till get to around 3000 rpm then does same. Went to mates garage fault codes p1517 and p1112 he told me they were coded anti start operation and fuel rail pressure?

Any one with any info on problem and fix would be great

Thanks ben
Reply
#2
Any ideas or solutions?

Thanks
Reply
#3
P1517 CODED ANTI-START OPERATION
P1112 FUEL RAIL PRESSURE

The first code I believe is the ECU's response to the second code in not allowing the engine to start.
The second code could indicate anything in the fuel line from a blocked or worn out injector to a failing
fuel or injector pump.
I'm no expert but I would take the car to a competent independent garage for a full check
and measurement of the fuel rail pressure plus an injector check.
Maybe one of our experts will be along later to give you more detailed/accurate advice.

Oh! Welcome to 'our' place!
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#4
Many thanks for the reply,

I wasn't sure if there was a common fault with them that someone may know. I have booked it for a full service so will see if fuel filter helps first if not will get get checked whilst at garage.

Any other ideas etc would be great.

Thanks again ben
Reply
#5
No problem, Ben. What mileage does the van have?
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#6
A lot lol traveled to moon and back few times.

216k.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 132
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 42
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 14
Fuel consumption
Last Post:ron
Yesterday 09:41 PM
» Replies: 12
» Views: 275
Rear Wiper Motor
Last Post:minisandfords
Yesterday 08:48 PM
» Replies: 2
» Views: 80
Lower Ball Joint
Last Post:brodfather11
Yesterday 08:38 PM
» Replies: 2
» Views: 69
Bottom Ball joint
Last Post:Andyy
Yesterday 08:26 PM
» Replies: 6
» Views: 82
cutting out HDi 1.6 diese...
Last Post:Col
Yesterday 06:15 PM
» Replies: 18
» Views: 1437
Poor cold startup 1.9
Last Post:Top drive
Yesterday 06:10 PM
» Replies: 34
» Views: 804
starting problem
Last Post:brodfather11
Yesterday 03:32 PM
» Replies: 1
» Views: 41

Locations of visitors to this page