Thread Rating:
  • 11 Vote(s) - 3.09 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MIL and Error Codes
#1
Hi
While driving in town today, the MIL came on after engine hesitated slightly at around 3000 rpm. The MIL went out again after the third start-up sicne it came on (engine never went into limp mode) and has stayed out since. Engine is running fine otherwise

I plugged my code reader and got the following

P0087 Fuel rail pressure too low (fuel filter?)
P1351 ??.

There was also a P1351 showing as pending. Having searched here and various forums, any explanation for P1351 may well have been written in Swedish for all the jargon made sense.

The van is booked for its next service next week anyway, and is due a fuel filter change this time around. If someone can give me a plain explanation for this, and whether or not the codes are linked, I would be grateful.

Van is a 2008/58 1.6HDi Enterprise

Thank you
Reply
#2
P1351 seems to relate to the glow plug circuit - possibly the relay.

P007 could be the fuel filter, the pressure sensor or there may be a small filter behind the pressure sensor which can become blocked giving the sensor a low reading
[+] 1 user says Thank You to Coco for this post
Reply
#3
(23-11-2012, 03:40 PM)Coco Wrote:  P1351 seems to relate to the glow plug circuit - possibly the relay.

P007 could be the fuel filter, the pressure sensor or there may be a small filter behind the pressure sensor which can become blocked giving the sensor a low reading

Thanks for that, Coco. It hesitated a bit at 3000 rpm, but to be honest it very rarely hits those revs in low gears so that would probably be why it runs ok normally.

As for glow plugs, the only time I get the coil warning light is if it's very cold in the mornings so never had any problems starting it. The garage it's going into on Monday is a local Citroen-savvy workshop who come recommended so am sure they will get to the bottom of it without ripping me off!
Reply
#4
If you trust the garage and they treat you right, keep going back - they deserve your support.

On the HDi you will only see the glow plug light when it's zero degrees and then only for a second or two
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 25
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 57
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 32
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 34
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 261
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 116
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page