Thread Rating:
  • 10 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
window wipers seem to be very slow?
hello all,
I recently purchased a 52 plate berlingo van off of a friend, and the window wipers seem to be very slow? is this normal?
Ive got a mk2 but I think yours are the same you should have 3 speeds, intermittent, slow speed and then faster speed.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
The motor is dying, happened on my mk1
Somedays you're the pigeon, Somedays you're the statue.
(05-12-2012, 06:24 PM)Berlingooooo Wrote:  hello all,
I recently purchased a 52 plate berlingo van off of a friend, and the window wipers seem to be very slow? is this normal?

What you can try,if it's not too late,is remove the wiper arms & drip,not spray,WD40 on the spindles.Run for a second or 2 & repeat.
Let it soak & repeat.
Refit arms & check for improvement.If better,apply light oil to the spindles daily for a week,running with the wipers in the up pos,(in the unlikely event it's not raining).
Good luck.
Strawberry flavoured windows  Dodgy
I had a similar problem on my 2.0Hdi The wipers always appeared slower/noisier than on my previous 1.9 Then one evening after not bothering to turn off my wipers before the ignition and when turning on the ignition next morning the wipers moved to park but were frozen to the screen result no wipers and a knackered wiper gear box,Sad stripping down revealed a groove worn in the plastic worm drive thingy so this had most likely happened before. I found a matching part at my local breaker for £10 and hey presto my wipers were back to the speed of my previous model Lingo:woop:, they had been running that way for at least 5 years I just put it down to model/manufacturing differences. WARNING Do not try to operate the wipers with them raised off the screen as they take the paint of the rear edge of the bonnet:whistle:
Thanks for the warning,I assumed they would clear in the up pos.Lesson learned,never assume.
Strawberry flavoured windows  Dodgy

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Still on the elusive 4x10...
Last Post:Col
Today 09:05 PM
» Replies: 6
» Views: 179
Bump and Run - Am I right...
Last Post:Opensauce
Today 08:37 PM
» Replies: 20
» Views: 340
I'm hearing better or smt...
Last Post:Johny555
Today 08:31 PM
» Replies: 15
» Views: 394
2012 berlingo radio setti...
Last Post:Jed Clampit
Today 08:29 PM
» Replies: 14
» Views: 354
Newbie checking in
Last Post:Jed Clampit
Today 08:12 PM
» Replies: 2
» Views: 46
Eco activated but engine ...
Last Post:Satellitemark
Today 07:02 PM
» Replies: 30
» Views: 846
DPF Regeneration
Last Post:doofer
Today 06:39 PM
» Replies: 6
» Views: 204
Diagnostic "gear" / Softw...
Last Post:doofer
Today 06:33 PM
» Replies: 11
» Views: 289
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 05:37 PM
» Replies: 2
» Views: 95
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 167

Locations of visitors to this page