Thread Rating:
  • 5 Vote(s) - 3.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heating schematics
#1
Hi all,recently managed to break my heating on my mk1 1998 berlingo. The control switch 1-4 was stiff and after a bit of pressure released....only problem is the heater motor is running and producing heat...its just not being directed to the heating vents.I can see there is some rubber hosing loose in centre panel maybe all the heat is escaping there

Anyone else had this problem

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Washers not working
Last Post:CourierJim
Today 06:25 PM
» Replies: 9
» Views: 242
Reverse light switch prob...
Last Post:cancunia
Today 06:24 PM
» Replies: 11
» Views: 223
Fuse is burning all the t...
Last Post:fernandoblas
Today 05:23 PM
» Replies: 12
» Views: 399
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 04:31 PM
» Replies: 2
» Views: 56
Diagnostic "gear" / Softw...
Last Post:cancunia
Today 04:19 PM
» Replies: 15
» Views: 603
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1020
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 79
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 80
Trip Computer on Type A M...
Last Post:cancunia
Today 09:18 AM
» Replies: 1
» Views: 63
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 124

Locations of visitors to this page