Thread Rating:
  • 6 Vote(s) - 3.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
electrical problem - non start
#1
Hi, i'm new to this forum, recently purchased 03 model van 1.9d, everything perfect until when i went to start it on saturday. ignition lights come on, engine turns over but doesnt start. also noticed, the glow plugs aren't coming on, blower motor & wipers dont work. All fuses ok, removed bsi and visually examined it, no signs of water or other damage. Any help/advice would be apprieciated before i start spending big money on it
Reply
#2
Hi, did you get two sets of keys, if you did try the other one.
Is there any white smoke coming from the exhaust? Confusedcratch:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
(19-12-2012, 04:38 PM)Rustscrat Wrote:  Hi, did you get two sets of keys, if you did try the other one.
Is there any white smoke coming from the exhaust? Confusedcratch:

Only one key with the van, no white smoke from exhaust
Reply
#4
Hi i had a simular problem a few months back my van just cut out on the way home from work and when i tried to start it i noticed that the glow plug light had gone anyway it went in to citroen and ended up being the bm34 fuse board thats the one near the battery had tried everything before that bsi/ecu/all fuses but it took citroen to find the problem
Reply
#5
Could be the immobiliser hasn't unlocked as there is no smoke.
Check the transponder coil around the ignition switch for continuity.
I've had one where the wire had come of the soldered connection. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Check your fuel cut off switch in the engine bay. red switch left hand side on my MK1 1.9d.

My front springs broke and the shock of it made the car think it was in a accident. when i came to start the car the hazards would come on every time. No fuel so would crank all day but not even a hint of smoke out the back. pushed the switch on the top heard a click and it started first time.
[+] 1 user says Thank You to Ricbob123 for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 19
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 56
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 30
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 32
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 113
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page