Thread Rating:
  • 6 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
serviced and still poor mpg
Hi everyone,

First van i have owned and has the worst mpg so far. its a 1.9d 1999 van with 144k. Ive just done a small service on it cam belt, aux belt, fuel filter, air filter, oil and filter. petrol light came on so put bp ultimate in £30 at 1.46 ltr. (not cheap i know) just to run it with some good fuel to maybe help clean the fuel ways im currently at 90 miles and not far off the light coming on may hit around 110-120 at best and had nothing in the back either! wheel pressures was done before this too. also seems you need to really put your foot down for this van to move, are they all like this?

what can it be as im sure it can do better.

its a mixture of motorway and town.
Sounds like you have covered the basics, maybe valve clearances are wrong, although this usually causes poor starting.
Check the cold start device on the pump, it is a cable device operated by a wax stat next too the top hose. When they fail, they stick full on, raising the idle speed and fuel mixture.
I have just disconnected mine, on my C 15. Still starts and runs fine.
[+] 1 user says Thank You to Lighty for this post
There was a thread on here recently about the cold start device and how to replace it and these 1.9 vans are a bit of a plodder but reliable. Are the brakes sticking slightly, only way to do an accurate check on fuel is full tank to full tank as the
gauges have a big margin.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 2 users say Thank You to Tomcat3 for this post
thank you all for the replies, i have noticed on my slightly slopped drive my zafira rolls on its own once the handbrake has been released as where the berlingo needs a bit of help. may look at the drums/handbrake shoes . Also is the a pic of this device? cannot find this thread.
Have a look at this thread
I think its in here.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 1 user says Thank You to Tomcat3 for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2012 berlingo radio setti...
Last Post:NANO_Vigo
Today 02:19 AM
» Replies: 10
» Views: 212
Dead BSI unit?
Last Post:Jed Clampit
Yesterday 10:18 PM
» Replies: 2
» Views: 28
Black Smoke
Last Post:Jed Clampit
Yesterday 10:07 PM
» Replies: 3
» Views: 87
Strange exhaust blowing n...
Last Post:dieselj
Yesterday 10:00 PM
» Replies: 1
» Views: 38
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 356
DPF Regeneration
Last Post:Jed Clampit
Yesterday 09:46 PM
» Replies: 4
» Views: 73
New Battery
Last Post:Jed Clampit
Yesterday 09:35 PM
» Replies: 3
» Views: 66
Window mechanism replacem...
Last Post:Kez
Yesterday 09:01 PM
» Replies: 2
» Views: 62
Air Vent Directors Loose
Last Post:doofer
Yesterday 08:19 PM
» Replies: 2
» Views: 202
Roof bars for VTR?
Last Post:ffrenchie
Yesterday 08:01 PM
» Replies: 6
» Views: 132

Locations of visitors to this page