Thread Rating:
  • 8 Vote(s) - 2.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
POWER WINDOW ASSEMBLY
#1
Hi all

My problem is with 2002 Berlingo 1.4l RHS (driver side) power window regulator assembly.
In the 10 years of ownership the window has probably only been activate 20 times (only 7,000 km on odometer). Never the less it failed. Pulled it out to find small plastic cable retainer broken. There are three of these at top and bottom of both the guide channels, they anchor the operating cable and feed it onto the pulleys at top and bottom of the guide channels. A fourth retainer at the base of the rear channel (see photo) is a more substantial plastic clip.
Inner cable (the steel wire) was frayed which probably caused the problem but I decided to fabricate a replacement for the broken plastic clip to see if the assembly operation could be recovered.
Made and fitted this OK but then found that I could not replace the wire cable around the pulleys at top and bottom of the guide channels. Problem is the cable(s) outer sheaths are too long to enable them to be fitted into the four corner clips. The cable outer sheathes fit into spring loaded entries into the regulator winch assembly - these allow adjustment of the cable outer lengths but the adjustment is insufficient, with the outers being about 30mm in total too long. How do I assemble the cables to the assembly?
This is a complicated story but anyone who has pulled a window regulator out of the door will understand the problem.
I forgot to take photos after removing assembly from door but show one with assembly still in door showing the large plastic clip and the rear guide channel.
Service manual does not give any detail except how to remove assembly from door.
Can anyone suggest why the cables will not re-install?
New assembly A$500 ex France three weeks delivery!


Attached Files Thumbnail(s)
   
Reply
#2
The cables usually cross over at the far side of their drum, away from the sheaths - is that how you set it up?

You can buy complete refurb kits, cheapest to Australia is from Okzam Germany (Fleabay) at about $53 with postage: http://www.ebay.de/itm/140404373139
Reply
#3
(09-01-2013, 09:04 PM)addo Wrote:  The cables usually cross over at the far side of their drum, away from the sheaths - is that how you set it up?

You can buy complete refurb kits, cheapest to Australia is from Okzam Germany (Fleabay) at about $53 with postage: http://www.ebay.de/itm/140404373139

Thanks for the response ADDO - amazed that you are in Australia too

I am not sure what you mean by the cables crossing over. The sheathes extend to each corner of the vertical guide channels where they terminate in the plastic retainers just before the inner cable engages the plastic pulleys directing the cable into the guides. The sheathes cross over in an X pattern between the guides.

Your refurb kit reference is great - thank you. Do you have experience of inserting the cables into the winder/motor assy. This does not seem to be capable of being dismantled?
Reply
#4
I did a Xsara coupé last week, it had the Meritor motor and anti-pinch assembly. In that case three screws released the motor drive from the cable drum. Except for the anti-pinch I think yours would be very similar.

On the plate where the motor mounts, the cable drum there - make sure you have wound the cables on in the correct order; this is where I was referring to how they cross over. After seating the drum and refitting the motor I locked in the outer cable ferrules to the motor mount plate - attempting it before refitting the motor seemed very hard/impossible.
Reply
#5
(20-01-2013, 03:59 AM)addo Wrote:  I did a Xsara coupé last week, it had the Meritor motor and anti-pinch assembly. In that case three screws released the motor drive from the cable drum. Except for the anti-pinch I think yours would be very similar.

On the plate where the motor mounts, the cable drum there - make sure you have wound the cables on in the correct order; this is where I was referring to how they cross over. After seating the drum and refitting the motor I locked in the outer cable ferrules to the motor mount plate - attempting it before refitting the motor seemed very hard/impossible.

Thanks for that
I have put it back in the door temporarily for vehicle security. Will look at your info when I remove again soon
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1413
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 773
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 27
Lower Ball Joint
Last Post:brodfather11
Today 03:36 PM
» Replies: 1
» Views: 43
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 34
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 140
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 32
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 103
peugeot charger
Last Post:3rensho
Today 06:46 AM
» Replies: 3
» Views: 104
Aftermarket radio stalk C...
Last Post:Matt Haigh
Yesterday 11:53 PM
» Replies: 7
» Views: 268

Locations of visitors to this page