Thread Rating:
  • 16 Vote(s) - 2.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
04 2.0 Hdi Engine Judder
#1
Hi All.
I've searched the forum and found some possible answers, but the other problems seem to be slightly different.

My 04 2.0 Hdi 82K has a bit of a running problem..

The car starts when requested and idles nicely - no probs there.
Firm acceleration is smooth and rapid - no probs there .
Blasting down the road, or motorway, it's fine - no probs either.

Yet slow acceleration and gentle throttle, from Cold or Hot, nearly often than not results in a juddering of the engine. It may be a red herring but it seems worse between 1500-2000 rpm.

I've checked for air in the fuel line, cleaned the MAF and also fitted new glow-plugs as it was starting slowly.

Am I correct in thinking the EGR valve could be at fault?.Confusedcratch:

Any pointers or ideas will be appreciated.

Thanks, Martin.
Reply
#2
Mine does same around 30mph in 4th gear if i only lightly touching, if i press the throttle on some more it stops at speed increase slightly. I have always put it down to being in wrong gear for the speed as i thing the gear ratios are set up differently on it and they have a longer range. On mine i have a gearbox/engine mount somewhere which is on its way out as well so when it does judder it is made worse by the slight knocking noise of the engine mount
[+] 1 user says Thank You to BerlingoHDI for this post
Reply
#3
Just to add, my 2003 HDi (110k) does same. Don't think it is engine mounts. Top one got changed recently when garage changed timing belt. But still get judder. As BerlingHDi, I assumed it was too low revs.
Reply
#4
Tbh....I cant see that being the cause.
I've noticed it happening up to 2k & I can't see Citroen making Diesels that need to be revved above that just to keep going, let alone the fuel economy harm.
My Scudo van has the same lump (+turbo) and thats happy pulling from 900.
Thanks for the suggestion though.
Reply
#5
when i say engine mounts i not sure if it a gearbox mount, mine judders but when it does it is made worse because of the mount, it feels like a mount at bottom of engine but i not too sure as i not been underneath to look. Mine also as a slight knock on start up and when switching engine off, the judder and knock might not be connected though and i do believe it is gearbox ratios
Reply
#6
(09-01-2013, 09:35 PM)BerlingoHDI Wrote:  Mine also as a slight knock on start up and when switching engine off, the judder and knock might not be connected though and i do believe it is gearbox ratios

My old lingo had a similar sounding knock, it turned out, after a lot of searching with the aid of a lift, to be the mount under the engine, not the gearbox. The bolts securing the metal plate part of the mount to the chassis were loose, causing the knock. It wasnt obvious to the eye the movement wasnt great but enough to make the sound travel through to the body wrk and so to the interior. After tightening the sound disappeared. Worth checkng maybe?
[+] 2 users say Thank You to mrbritse for this post
Reply
#7
(09-01-2013, 10:00 PM)mrbritse Wrote:  
(09-01-2013, 09:35 PM)BerlingoHDI Wrote:  Mine also as a slight knock on start up and when switching engine off, the judder and knock might not be connected though and i do believe it is gearbox ratios

My old lingo had a similar sounding knock, it turned out, after a lot of searching with the aid of a lift, to be the mount under the engine, not the gearbox. The bolts securing the metal plate part of the mount to the chassis were loose, causing the knock. It wasnt obvious to the eye the movement wasnt great but enough to make the sound travel through to the body wrk and so to the interior. After tightening the sound disappeared. Worth checkng maybe?

Thanks for that, when weather is better i may check that out but at moment it aint really bothering me,

thanks again
Reply
#8
Yes as suggested above....up on a lift and check the lower engine mounting(s).
They can come loose after time.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#9
Surely, if I had a loose engine mount the gear lever would lurch forth and back under acceration and quick braking.?. I've got none of those problems...
I will get it on a lift shortly, just out of interest.
Reply
#10
The movement can be minimal in that you won't notice it from the cabin, but it translates to a healthy knock when metal contacts metal.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Haynes manuals - which on...
Last Post:jj9
Today 10:08 AM
» Replies: 1
» Views: 14
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 13
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Today 10:01 AM
» Replies: 9
» Views: 157
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 158
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 157
Heyup
Last Post:Mojow Royle
Today 09:06 AM
» Replies: 5
» Views: 247
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 266
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 142
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 07:27 PM
» Replies: 16
» Views: 388
Roof noise
Last Post:Opensauce
Yesterday 06:39 PM
» Replies: 5
» Views: 142

Locations of visitors to this page