Thread Rating:
  • 7 Vote(s) - 3.14 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuel Filter
#1
Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Reply
#2
Open the drain and see what comes out.
[+] 1 user says Thank You to corkgsxr for this post
Reply
#3
(22-01-2013, 10:13 PM)kevinp Wrote:  Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Words fail me! What sort of garage would give such advice! There is obviously a problem that would be recorded in the ECU.
My advice would be to check with a proper garage.
Reply
#4
Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

It was one of those chinese fake brands-very subtle
Reply
#5
(22-01-2013, 11:27 PM)andylobb Wrote:  
(22-01-2013, 10:13 PM)kevinp Wrote:  Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Words fail me! What sort of garage would give such advice! There is obviously a problem that would be recorded in the ECU.
My advice would be to check with a proper garage.

It was my main Citeron Dealer.
Reply
#6
Engine fault light came on this morning for abot an hour then went off, cars been running fine all day.
Goint to change filter tomorrow.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 19
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 56
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 30
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 32
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 113
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page