Thread Rating:
  • 4 Vote(s) - 3.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silver flakes in fuel filter housing?
#1
Ive been checking this van for possible causes as to why the power has dropped suddenly, and found silver flakes in the bottom of the filter housing?? What is this?
Reply
#2
I assume you mean the fuel filter.I suspect fuel pump wear which may cause your lack of power.Have the pressure checked.
Strawberry flavoured windows  Dodgy
Reply
#3
Yes sorry, the fuel filter hosuing, was running fine then suddenly..low power, taking it to a garage on Tuesday to get it checked properly. Would it be the low pressure or high pressure pump thats causing the flakes?
Reply
#4
(10-02-2013, 07:44 PM)BrookWCServices Wrote:  Yes sorry, the fuel filter hosuing, was running fine then suddenly..low power, taking it to a garage on Tuesday to get it checked properly. Would it be the low pressure or high pressure pump thats causing the flakes?

Usually the hp I'm afraid.:censored:
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#5
Oh dear Sad Well I i`ll find out tomorrow what it is and report back Smile Thanks
Reply
#6
Good luck or you will have to take up busking.
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#7
How much silver flakes? There's been a tiny bit in the bottom of mine every fuel filter change for three years, I change my filter every 6k
Somedays you're the pigeon, Somedays you're the statue.
[+] 1 user says Thank You to steve valentine for this post
Reply
#8
I would say a tiny bit also, looks like dandruff, hard too describe the amount, the first time I changed the filter it was black, literally black, so god knows when it was last done, I threw it away so cant show you but i can upload a picture of the air filter for a laugh, the guy before me seems to have drove it till it stopped.. But i like the challenge of bringing things back to life and i really like the van..Ive come this far Smile Taking it in the garage tomorrow morning so will post back the results..as for now..i will post the filter Smile
Reply
#9
(11-02-2013, 10:37 PM)BrookWCServices Wrote:  I would say a tiny bit also, looks like dandruff, hard too describe the amount, the first time I changed the filter it was black, literally black, so god knows when it was last done, I threw it away so cant show you but i can upload a picture of the air filter for a laugh, the guy before me seems to have drove it till it stopped.. But i like the challenge of bringing things back to life and i really like the van..Ive come this far Smile Taking it in the garage tomorrow morning so will post back the results..as for now..i will post the filter Smile

Saying you had a sudden loss of power & metal flakes in filter I put 2+2 together & may have come to 5.If the old filters were as grotty as you say,a dose of a GOOD fuel system cleaner & a hard run(don't thrash it)
may be the answer to your(or a maidens') prayer.:thumbsup:
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Reply
#10
When i changed the fuel filter it stopped the engine going into limp mode at 3000rpm, all was fine until last week when i pulled away and there was little to no power and blue smoke, changed the air filter and it got worse? My 10 month old daughter can crawl quicker than it at the moment so i think a thrash is out of the question..Thanks for your help, will know more tomorrow Confusedtudy:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 91
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 19
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 56
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 30
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 32
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 76
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 113
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 470

Locations of visitors to this page