Thread Rating:
  • 9 Vote(s) - 2.89 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Jump starting WITH your Berlingo
#1
Anyone tried to jump start another car with your Berlingo? Was trying to revive our elderly and very dead Saab yesterday with the Berlingo and.... Nothing. Used the BMW as I have in the past and the Saab turned over straight away. Weird. Must have been doing something wrong but no idea what...
Reply
#2
I've used mine to jump start my old Bluebird on afew occasions and it worked fine!

*Well,the jump leads had a bad habit of melting lol
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

Reply
#3
Have used my Blingo to jump a teeny weeny petrol mini and a 1.9D kangoo van without any issue :thumbsup:
Reply
#4
Positive from battery to positive on the dead car battery and negative from the battery to an earth point on the tow car. Did you do it this way?
Reply
#5
(04-03-2013, 09:24 PM)Baldricks Pilot Wrote:  Positive from battery to positive on the dead car battery and negative from the battery to an earth point on the tow car. Did you do it this way?

Yeah - twice, cause I couldn't work out what I was doing wrong. The only issue I can think of is there isn't anywhere to get a really good grip on the +ive terminal on the Berlingo battery. Ah well...
Reply
#6
Jumped a 62 plate 4.4ltr V8 Range Rover just before Christmas.
The bloke was very grateful. It was a hire car and he had no idea why the battery had gone flat.
I did think afterwards that it was perhaps not a good idea? Confusedcratch:
But the little Berlingo suffered no ill effects...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 24
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1087
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 40
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 310
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 272
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 40
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 419
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 82
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 621
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 93

Locations of visitors to this page