Thread Rating:
  • 23 Vote(s) - 2.74 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cooling Fan not working
#1
I need to lovcate the reason why my cooling fans does not work.
I tried to disconnect water temperature sensor and I saw that the needle of temperature mesurement in cabinet goes fully right but still fans does not comes on, I tried also turning on Air condition and the same problem.
Does anyone have electrical diagrams saw I will be able to locate the problem?
Reply
#2
Hi, try having a look at this topic
http://www.berlingoforum.co.uk/showthread.php?tid=3294
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
Is the vehicle overheating or is the gauge faulty ?
So where does this bit go then ?
Reply
#4
(15-03-2013, 09:57 AM)ffrenchie Wrote:  Is the vehicle overheating or is the gauge faulty ?

The guage is ok, Vehicle is overheating due to the fact that Fans will not start
Reply
#5
Hi, if you P/Mail me your Vin No. I'll see what I can dig out. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Sorry for the delay, this should be your circuit.
The coolant / AC sensor is a 4 pin blue unit (4040). The two pin green is for the egr valve. Confusedalut:

[Image: 29x7pqp.png]
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
I have replaced the 3 relays on the Fans assembly to new ones and problem is gone.
Thank you all!!!
[+] 2 users say Thank You to aganim for this post
Reply
#8
Nice one, thanks for letting us know. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
(21-03-2013, 12:36 PM)Rustscrat Wrote:  Nice one, thanks for letting us know. :thumbsup:

New Problem...

I had 3 times 50A fuse blown up, It suddely burnned out and I was not able to start the engine until found this fuse under hood.
I have notticed last time that it happend imediatly after turning Air Conditioner On.
Please advise.
Thanks,
Eli.
Reply
#10
Can you tell us the number / identity of the fuse Confusedcratch: :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
citroen berlingo desire 1...
Last Post:sks01773
Today 10:16 PM
» Replies: 0
» Views: 2
B9 DPF Tank Top-Up
Last Post:Lighty
Today 10:06 PM
» Replies: 5
» Views: 107
Rear light Cluster
Last Post:Peter Guy
Today 09:57 PM
» Replies: 2
» Views: 12
2012 enterprise berlingo ...
Last Post:CourierJim
Today 09:03 PM
» Replies: 6
» Views: 111
Head gasket failure.
Last Post:Civvic
Today 08:08 PM
» Replies: 13
» Views: 349
At last
Last Post:Gerald Bostock
Today 08:06 PM
» Replies: 9
» Views: 318
Conversion from manual to...
Last Post:Civvic
Today 07:58 PM
» Replies: 1
» Views: 83
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 40
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 97
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1781

Locations of visitors to this page