Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery light?
#1
Hi
after some ideas before i take it to be looked at.
Today whilst driving home, the battery light came on (and beeped),I kept driving, then it went off again, then a while later came on again, then just as i pulled in home it had gone off again?
The battery was new a while back so it cant be dud already?
The van still drove like it always does.
also it doesn't like to start first time when its cold, but never fails to start, connected?

Hope its not an expensive problem
[+] 1 user says Thank You to cornishbecky for this post
Reply
#2
Check:- all batt connections,all earth connections & Alternator terminals.Also check the alt belt is ok.Good luck.
Strawberry flavoured windows  Dodgy
Reply
#3
Well my vans in the garage after failing to start..........

They have not been that successful in explaining the possible problem to me, They are having and electrical person look at it tomorrow as it is possibly the ?electric board? that would need a Citroen garage to deal with it?????? sound pricey.
Reply
#4
(20-03-2013, 06:54 PM)cornishbecky Wrote:  Well my vans in the garage after failing to start..........

They have not been that successful in explaining the possible problem to me, They are having and electrical person look at it tomorrow as it is possibly the ?electric board? that would need a Citroen garage to deal with it?????? sound pricey.

Oh,double poo.:censored:
Strawberry flavoured windows  Dodgy
Reply
#5
Could also be the alternator losing a diode.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:AlanDeejay
Today 01:48 AM
» Replies: 0
» Views: 6
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1078
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 33
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 303
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 262
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 31
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 416
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page