Thread Rating:
  • 5 Vote(s) - 2.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] oil in expansion tank?
#1
Sad 
Hi there guys i have a problem with my van i have oil in my expansion tank!!:brickwall:

now i had this a few months ago drained it all off and used K.seal it satyed away till now.

its a lot of oil too in there.the oil cap has no signs of head gasket foams ect.

the van does not over heat.
its starts and runs ok

its a non turbo model 1.9d it has never pulled well i may add since ive had it.

can anyone shed a light on what it could be i read it could be the oil cooler?

many thanks.
Reply
#2
It can come from internal corrosion in the oil cooler; this was more common in the era of cast alloy oil coolers, also a source of mingling is the head gasket where it has an oilway near the cooling pasages.

Oil is up to four times the pressure of water in your block; it's far easier for the oil to "squeeze" into a water gallery past a dying gasket than vice-versa. This is why K-seal (etc) are not such reliable fixes; they're on the wrong side of the hole.
[+] 1 user says Thank You to addo for this post
Reply
#3
ok what would you suggest is the best thing for me to do this is my work horse and i rely on it.

how long would it last been driven like this?will it just pack up before long?


thanks again for the reply.
Reply
#4
i need to get rid of this van i think things going all over are the relay vans anygood?
Reply
#5
(20-03-2013, 11:01 AM)addo Wrote:  It can come from internal corrosion in the oil cooler; this was more common in the era of cast alloy oil coolers, also a source of mingling is the head gasket where it has an oilway near the cooling pasages.

Oil is up to four times the pressure of water in your block; it's far easier for the oil to "squeeze" into a water gallery past a dying gasket than vice-versa. This is why K-seal (etc) are not such reliable fixes; they're on the wrong side of the hole.

I totally agree about your diagnosis,there's nothing worse than being on the wrong side of the hole.:drool::whistle:
Strawberry flavoured windows  Dodgy
Reply
#6
Too high, too low, too late! Two bob...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 427
Rear hub nut torque setti...
Last Post:cancunia
Today 01:47 PM
» Replies: 13
» Views: 184
temperatue dial
Last Post:polar
Today 11:47 AM
» Replies: 1
» Views: 25
Loud beeping from radio u...
Last Post:Tree
Today 08:35 AM
» Replies: 2
» Views: 68
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 52
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 215
increase in a ratchet-typ...
Last Post:saskak
Today 12:36 AM
» Replies: 7
» Views: 145
Rear Wiper Motor
Last Post:madwelshman
Yesterday 10:42 PM
» Replies: 3
» Views: 123
Heater control unit/resis...
Last Post:mreid63
Yesterday 10:34 PM
» Replies: 5
» Views: 348
Facial light replacement
Last Post:Mike
Yesterday 09:23 PM
» Replies: 11
» Views: 306

Locations of visitors to this page