Thread Rating:
  • 14 Vote(s) - 3.64 Average
  • 1
  • 2
  • 3
  • 4
  • 5
metal shavings in fuel filter
#1
Hi ive just bought a 56 plate 1.6hdi berlingo and was giving it a service today eg new filters and oil. when i took the fuel filter out there was metal shavings under the filter! would this mean the fuel pump was on its way out?? or what would the shavings be from?

the van takes a while to start in the morning but starts fine for rest of the day ive bought new heater plugs but am thinking about taking them back if its the pump thats causing the problem!

any advice or suggestions would be greatly appreciated.....

thanks
brent
Reply
#2
need a photo really as you can get some metal particals from the fuel pump in the filter as the norm. The problem is the ammount (if its lots it is the pump) so its difficult to say without seeing it myself.

Do you have a plug and play filter on yours or the elliment type - just wondering if you had to prise it open to check the old filter - i do with mine!

As for the cold start problem it could be a few things, is the starter turning it over fast enough in the morning? It could also be fuel run back, like i say many things.

You could do with a diag as the first port of call
Reply
#3
........ Every Citroen diesel I've ever had over the years has had some metal flakes in the filter housing so it isn't necessarily a " problem " as such depending on the amount of flakes of course. What you need to consider is how well the vehicle runs and how your economy is as a yardstick to the engine / pump condition ( metre stick in these modern times ??? )......

The starting thing could be absolutely anything and nothing ....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:Hector Scorn
Today 12:51 AM
» Replies: 2
» Views: 85
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 15
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 54
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 26
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 30
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 260
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 73
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 25
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 110
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 469

Locations of visitors to this page