Thread Rating:
  • 9 Vote(s) - 2.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BSI/CLOCKS ISSUES
#1
Hello :wave:

Any advice is highly appreciated!

I have a x/2000 berlingo van with strange problems. The clocks/instrument panel was having fits. The fuel gauge was all over the place making a clicking sound and the revs and speedo made no movement at all also the mileage was reading zero's.

I bought some new clocks and fitted them today which has stopped the strange ticking sound but still no revs/speedo and mileage is still reading zero's.

A separate issue but maybe worth mentioning is I have no heater fan and central locking doesn't work

The indicators, lights, wipers and washers work, it starts and runs fine and has no other problems other then what I've mentioned. I've had the bsi out and checked for water damage, I checked all the earths, changed all the fuses for new ones and done the bsi reset a couple of times.

I have two keys but the one with buttons on doesn't turn the ignition and only opens and closes the front doors. This leads me to believe that its possibly had a new bsi,ecu and key at some point, is there any way to confirm this?

Thanks



EDIT - In the drivers side footwell I found four damaged wires, looks as if someones had something fitted to them in the past. I've wrapped them in the yellow electrical tape but its the three connected to the green plug and the red one going in to the bsi. Perhaps this is connected to my problem. Any idea what the green plug is for?

[Image: 5413_zpsac01be9d.jpg]
Reply
#2
Hi, the green plug is from your ignition switch.
Have you just obtained the van with the fault or has it just developed ?
:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
(05-04-2013, 02:15 PM)Rustscrat Wrote:  Hi, the green plug is from your ignition switch.
Have you just obtained the van with the fault or has it just developed ?
:thumbsup:

Hi, thank you for that it's obviously not the problem then. I obtained the van with the issue thinking it would be an easy fix :brickwall:

I didn't pay much for it though and it gives me something to play with Big Grin
Reply
#4
Nice one, I like a challenge as well :eek:
If you P/Mail me your Vin No. I'll see what I can dig out. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
(05-04-2013, 02:45 PM)Rustscrat Wrote:  Nice one, I like a challenge as well :eek:
If you P/Mail me your Vin No. I'll see what I can dig out. :thumbsup:

Thanks Rustscrat, I'll do that! Just a quick one about the ignition switch, if I unplug it should I still be able to start it?
Reply
#6
I wouldn't of thought so as there will be no ignition power or starter motor.:thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
(05-04-2013, 03:49 PM)Rustscrat Wrote:  I wouldn't of thought so as there will be no ignition power or starter motor.:thumbsup:

Perhaps it's not ignition? It starts perfect with it in or out. :S
Reply
#8
Ok, let me look at the drawings. Confusedcratch:

At the other side of the green plug, is there wires going to all 3 locations of the connector?
2006 2.0hdi 600 with bench seat.  Cool
Reply
#9
(05-04-2013, 04:22 PM)Rustscrat Wrote:  Ok, let me look at the drawings. Confusedcratch:

At the other side of the green plug, is there wires going to all 3 locations of the connector?

Yes there is, two white or grey wires and a brown one....
Reply
#10
Many apologies, this green connector is a main fuse feed from the engine bay fuse box. The black wire feeds the lighting stalks, and the brown feeds fuses 13,14,15 & 16 which leaves the grey which feeds a lot of other fuses. I'm presuming when this is separated nowt works front of house?
Have you checked all the fuses including the big main ones in the engine bay fuse box?

With ignition on check each side of these fuses (you should be able to probe the metal spots on top of them) with the neg probe to earth.
F5 in the engine bay fuse box (BM34).
F27,6,9 & 4 in the fuse box under the steering wheel (BH28).
You should get 12V on both sides of the fuses.
Let us know what you find. :thumbsup:

   
2006 2.0hdi 600 with bench seat.  Cool
[+] 1 user says Thank You to Rustscrat for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:Col
Today 07:22 PM
» Replies: 12
» Views: 243
2004 Berlino Aerial
Last Post:Claydontoby92
Today 07:14 PM
» Replies: 0
» Views: 14
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Today 07:05 PM
» Replies: 0
» Views: 15
Washers not working
Last Post:Silverberlingo
Today 06:54 PM
» Replies: 10
» Views: 268
Fuse is burning all the t...
Last Post:fernandoblas
Today 05:23 PM
» Replies: 12
» Views: 410
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 04:31 PM
» Replies: 2
» Views: 68
Diagnostic "gear" / Softw...
Last Post:cancunia
Today 04:19 PM
» Replies: 15
» Views: 612
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1031
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 86
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 80

Locations of visitors to this page