Thread Rating:
  • 3 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radio Question
Ive had my 03 Multispace Forte 1.9 diesel since October and so far without any major issuesBig Grin.
However my radio suddenly stopped working,the tape still plays but it doesn't receive the stations.
I'm thinking of buying a second hand unit,but being a Forte it only has the basic dash display,my question is will the functions still work normally if the radio from the donor vehicle is of a higher spec?
Have you checked the aerial is still connected and working? There is a likelihood
that moisture has got in and corroded the connections or that the plug has simply vibrated loose.
If that is the case a new radio won't cure the problem.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Im sure ive read on the forum that radio units are coded to the vehicle so you may have to get it decoded or sort it with lexxia software first but dont quote me on that. Some of the tech guys may have the answer for that and as Ol`jeffers says check the aerial mount in the roof first it could have water damage and poor earth.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
What's a tape player? Confusedcratch:
[+] 1 user says Thank You to j90xxx for this post
If the radio is faulty just buy an aftermarket one and the correct connecting lead as you won't need to bother about coding and according to my friendly Citroen Dealer the stereos are pants and aftermarket ones are better value.

We did this with our mk1 and it was fine. The only problem for you will be that it would not look as good in the curved dash.

Thanks for all the replies gents.
Jeffers,I dont think the aerial is the problem.Water was entering through the aerial base,I took all the contacts apart and sprayed them even though they looked OK,with still no ball.I put in another stereo that I had fitted to my old Pug Partner and it works perfect,but I would perfer that the proper unit for my model is fitted so I can still have use of the dash display and stalk controls.
I've got one for sale if you're interested?

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Front camber out of align...
Last Post:Civvic
Today 07:20 AM
» Replies: 2
» Views: 49
Berlingo VTR to ''XTR'' l...
Last Post:david.mckay.3760
Today 01:01 AM
» Replies: 3
» Views: 164
How the heck do I remove ...
Last Post:CourierJim
Yesterday 11:20 PM
» Replies: 7
» Views: 555
Wanted Berlingo / Partner...
Last Post:Matt Haigh
Yesterday 09:41 PM
» Replies: 1
» Views: 75
Storage pods removal How
Last Post:Michael Hills
Yesterday 09:20 PM
» Replies: 0
» Views: 25
Emptying out the cat conv...
Last Post:flashBE
Yesterday 09:12 PM
» Replies: 4
» Views: 223
Cruise control possible o...
Last Post:flashBE
Yesterday 08:58 PM
» Replies: 0
» Views: 36
1.6HDI 75 bigger turbo (f...
Last Post:flashBE
Yesterday 08:52 PM
» Replies: 4
» Views: 153
Timing belt - and accesso...
Last Post:flashBE
Yesterday 08:50 PM
» Replies: 17
» Views: 639
2006 1.6hdi - indicators ...
Last Post:pidgeonpost
Yesterday 08:03 PM
» Replies: 9
» Views: 198

Locations of visitors to this page