Thread Rating:
  • 5 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low Speed Misfire
#1
After my 2011 1.6 e-hdi broke down recently, Citroen dealer stated on invoice that there was fuel circuit fault and changed fuel filter, problem reoccured intermittently so went to other dealer who checked it but could find no fault, although they carried out ecu update. Problem still evident at low speeds , but as I say it is intermittent. Sent email to Citroen Uk and still waiting for replay. The car is still under warranty but I had to pay for diagnostics twice and for a new fuel filter. Any ideas ?, thanks.

Will be phoning them asap on their non-0844 number, which should be 01753 843000, or 0800 023400 > ( option 2 ) so I have been informed.
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#2
Struth; I'd be giving it a Viking funeral in their office foyer with TV crews filming away.
[+] 1 user says Thank You to addo for this post
Reply
#3
(20-04-2013, 12:09 AM)addo Wrote:  Struth; I'd be giving it a Viking funeral in their office foyer with TV crews filming away.
Hmmmm....:censored::lol:
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#4
They seriously do not understand what their warranty is supposed to be about. Any stumble should be in the fault logs, and they should be willing to read these details using DiagBox in your presence.
Reply
#5
First fault codes P0087, P0093 and P1113 shown referred to fuel pressure etc plus EOBD display lit up constantly but they just changed the filter as they said the diesel I purchased was to blame and charged me , .Also got code P0299 later. The car is now noiser on tickover and frequently " hunts ".
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#6
got my reply from Citroen UK today, so.........

Looks like no more Citroens for me then.
Former 2011 Mk3 XTR owner Confusedalut:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page