Thread Rating:
  • 7 Vote(s) - 2.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power Steering Leaking
#1
Hi All,
I have a 05 Mr2 Berlingo with the 2.0 HDI engine. I had decided to sell it to go for something bigger.
Last weekend I done a full cleanup of the van, engine bay too.
I found a Big oil leak form the power steering, need to get it on a lift to see where its coming from, Its at the back of the engine so I'm assuming it the ram or seals. Front of engine clean and dry, back very wet about half way down. Its def power steering fluid nd not engine oil.
Is there a history of seals or ram failure. Is it a big job to replace the rack if its knackered.
Cant believe I didnt spot this before now, had some people lined up to view the van. Typical !!
Reply
#2
There is no problems with Berlingo PAS.They wear like any other make.I change my fluid every 2-3 years & have never had problems.:thumbsup:Confusedalut:
Strawberry flavoured windows  Dodgy
Reply
#3
(30-04-2013, 08:36 PM)ron Wrote:  There is no problems with Berlingo PAS.They wear like any other make.I change my fluid every 2-3 years & have never had problems.:thumbsup:Confusedalut:

Thanks Ron,
I haven't got it up on the ramp yet so I don't know the exact problem.
Hopefully it's not the ram or it could get costly, it's hard to see it because of the cross member. Fingers crossed.
Reply
#4
FWIW mine now has a slow PAS leak - had to top it up a few months ago. Mentioned it when it had its service recently and they said prob OK to keep topping up unless it gets worse, as replacing would be an expensive job... but it has an MOT soon, so if they pick up on it may need to get it fixed.
Reply
#5
Well after closer inspection it wasn't the power steering. It was a sump gasket leak that was being thrown back on the power steering pipes and rack. New sump fitted 3 months ago and the wrong sealant was used and the leak just appeared now.
Sump off and some instant gasket and job done.
[+] 1 user says Thank You to webcrafty for this post
Reply
#6
(01-05-2013, 07:03 PM)webcrafty Wrote:  Well after closer inspection it wasn't the power steering. It was a sump gasket leak that was being thrown back on the power steering pipes and rack. New sump fitted 3 months ago and the wrong sealant was used and the leak just appeared now.
Sump off and some instant gasket and job done.

Glad it was not an expensive solution.:thumbsup::thumbsup::woop:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page