Thread Rating:
  • 3 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MAS problems/wiring diagrams
First post on this forum,
2001 Berlingo 1.9D ( DW8 engine)....just replaced a damaged air filter housing with one from a scrapper and noticed that the original Airflow sensor was damaged. The one in the replacement part appeared to look ok so I went with that one. However, as a quick test I disconnected it and found that there was no perceptable difference to the performance or running characteristics. Did a continuity test with all the 5 connections back to the ECU. 4 were ok and one had a resistance on it. So, thinking that could be normal I have now replaced the sensor with a Bosch one and lo and difference.
I'm now thinking that the one wire with a resistance could be the problem.
So....does anyone have a wiring diagram or a pin out for this model?
Also, am I right in thinking that this could be causing the engine managemant light to come on when in over run?

Think it's now sorted.....couldn't find a wiring diagram anywhere, but traced the wiring from the MASS to the ECU, found that the green/yellow is actually the ground, pin 1 is a steady 5v, pin 2 is 12v 3 is ground, pin 4 not used, pin 5 and six no voltage and therefore sensor returns.
Tried a new wire between both ends of green/yellow and it wouldn't start then realized it was infact ground. Ran a new earth from each end and hey presto, it's all working again. Faulty earth somewhere (not unusual of course!). So for future reference, both ends of that cable need to be earthed. (I had a resistance from one end). Whats more, the engine management light now stays off when in over run.

Hope this may be of help to someone.
[+] 3 users say Thank You to lesbarbeux for this post
Nice one thanks for the update it could be useful for another member in the future

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2012 berlingo radio setti...
Last Post:paulg
Today 01:47 PM
» Replies: 8
» Views: 173
Eco activated but engine ...
Last Post:doofer
Today 01:27 PM
» Replies: 24
» Views: 568
Roof bars for VTR?
Last Post:jimss
Today 01:11 PM
» Replies: 5
» Views: 103
Black Smoke
Last Post:3rensho
Today 12:46 PM
» Replies: 1
» Views: 28
flashing battery light
Last Post:snowman365
Today 10:40 AM
» Replies: 5
» Views: 439
cooling fans
Last Post:Luis Rosa
Today 10:34 AM
» Replies: 3
» Views: 78
P1351 fault code.
Last Post:Boxer
Today 08:26 AM
» Replies: 14
» Views: 800
My Berlingo Camper build....
Last Post:Sootyfoot
Today 05:11 AM
» Replies: 6
» Views: 318
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 269
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 250

Locations of visitors to this page