Thread Rating:
  • 4 Vote(s) - 1.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
coilovers
#1
Hi guys I finally got round to installing coilovers.ta tecknix ones were recommended by a user of this forum, but there is a problem when driving ay slow speeds (up to about 40) they are very clunky, it sounds like my front end is abot to fall of to be honest I've checked everything is tight and I just cant seem to find what is making thisuunbearable noise I was wondering if anyone could share some light on the matter as I know there are people on this forum with the same set up as me thanks

They do look great by the way


Attached Files Thumbnail(s)
       
Reply
#2
The ride they give is harsh, Though to be honest the knocking could be anything..Topmounts/bottom arms ect. Have you tried jacking it up and checking the wheel for play? I know when mine was recently knocking it turned out to be the bottom arm and droplinks.
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

[+] 1 user says Thank You to PeteA for this post
Reply
#3
Thanks pete I discovered the problem it was the helper springs clunking so I just rapped them in duct tape for now but they will be coming off when I do the torsion bars thanks for the help
Reply
#4
In My van, occured something like that. It was the top oh the shock knoling on the ecu coverage! Wink
Reply
#5
I never use the helper springs, as on bumpy roads they do exactly as you describe, and given the design on the coilover, the main springs will never re-seat incorrectly anyway. I also cut down the bumpstops as if you're going quite low, you'll find shock travel is restricted by them.
[+] 1 user says Thank You to FeuxLingo for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Lower Ball Joint
Last Post:Nichilli
Today 01:03 PM
» Replies: 0
» Views: 17
Washers not working
Last Post:Luis Rosa
Today 01:03 PM
» Replies: 5
» Views: 121
citroen berlingo alarm
Last Post:sks01773
Today 11:28 AM
» Replies: 0
» Views: 14
Reverse light switch prob...
Last Post:ffrenchie
Today 09:48 AM
» Replies: 6
» Views: 86
Poor cold startup 1.9
Last Post:cancunia
Today 09:03 AM
» Replies: 32
» Views: 749
peugeot charger
Last Post:3rensho
Today 06:46 AM
» Replies: 3
» Views: 100
Aftermarket radio stalk C...
Last Post:Matt Haigh
Yesterday 11:53 PM
» Replies: 7
» Views: 266
Carpet
Last Post:Shaunchippy95
Yesterday 09:50 PM
» Replies: 0
» Views: 50
2-Button Key Upgrade
Last Post:Matt Haigh
Yesterday 09:24 PM
» Replies: 0
» Views: 49
Fuel consumption
Last Post:ron
Yesterday 06:28 PM
» Replies: 9
» Views: 228

Locations of visitors to this page